1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Permissions / Ownership

Discussion in 'Plesk for Linux - 8.x and Older' started by jscherbel, Jul 2, 2005.

  1. jscherbel

    jscherbel Guest

    0
     
    I just recently moved a domain of mine from CPanel to Plesk. I copied the directory structure from my old server in to the httpdocs directory of the new server. Now that DNS has propogated, I notice some of the pages aren't loading and return errors or no page at all so I figure it's permissions/ownership of the files.

    I've been messing around with it but cannot get things to work. What should the ownership and permissions be on general PHP files in the httpdocs directory?

    URL is jazzfanz.com if it helps to see the problems. Click pretty much any link.

    Thanks
     
  2. tmonsen

    tmonsen Guest

    0
     
    The permissions for php should be 644, but it looks like you may have resolved the issue already, as the site is coming up without any problems for me.
     
  3. jscherbel

    jscherbel Guest

    0
     
    Actually it's not, click on any link in the left column except message boards. I just changed the permissions to 644 and now I get a blank white screen.

    Who should own the files? Maybe this isn't the problem. I just tarred up my old public folder and untarred them here. Originally they were all owned by root:root. I tried changing them to my "ftp" name and psaserv (like some of the stuff that was already there) but still get blank screens all over.

    Help!
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ownership normally would be ftpuser:psacln on the files/folders.

    Just to see if it's a perms issue, temporarily chmod -R 777 *.*

    When you chmod'ed before, you used the -R option to recursively affect folders and their contents, right?

    If that does not solve the blank screens then you'll need to look elsewhere for the problem. This is just a test, you can chmod them back afterwards.

    Also, do any of your php files have hardcoded paths, or paths based on the old server layout (Cpanel I believe is /var/www instead of Plesk's /home/httpd/vhosts/domain.com/httpdocs)

    Edit: Many of your pages which were blank are now working, but you may still have path issues:

    An Error Has Occurred! /includes/jf_header.php
    Nite Out '05

    And a perms issue:
    You don't have permission to access /features/niteOut/niteOut2004.php on this server.

    I haven't checked all possible links just some.
     
  5. jscherbel

    jscherbel Guest

    0
     
    Ok. Some of the blank screens were indeed a pathing issue. THANK YOU!

    Now that that is corrected, however, perms of 664 do not work. 777 does. My files are all owned by ftpuser : psacln.

    Any other ideas? I really appreciate the help!
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ok, so back off the perms from 777 in increments to see what the minimum you can get away with is.

    At 644 (as tmonsen posted) would not be giving any execute perms to any one/group.

    I think I would give Read to all, Write to Owner, Execute to Owner and Group as a minimum, which would be 754

    (or if no read to Other, then it would be 750)
     
  7. jscherbel

    jscherbel Guest

    0
     
    I was able to set all the files to 644 and it worked. Apparently my lovely chmod was changing the directories to 644 too which doesn't work well :)

    Thanks you two!
     
Loading...