1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP 4.3.2 to 4.3.3

Discussion in 'Plesk for Linux - 8.x and Older' started by ali_deren, Oct 19, 2006.

  1. ali_deren

    ali_deren Guest

    0
     
    I want to upgrade PHP version whis is 4.3.2 to 4.3.3

    How can i do this? My service provider said that upgrade your Plesk version, 7.5.4 to 8.0.1. But i couldn't success to upgrade. I got an error that said "gunzip can not read header files". Autoinstaller downloaded some files, but when tried to unpack archives of plesk 8.0.1, this error occured.

    Is there another way to upgrade my php version without upgrading Plesk?

    My server OS is RedHat_EL_3 with Plesk 7.5.4 Reloaded.

    Thank you.
     
  2. rpawlik

    rpawlik Guest

    0
     
    I have only heard of problems upgrading to PHP5 on Plesk 7.5.4. You should be able to upgrade to that version with no problems. You may want to try compiling PHP from source to do this. I have done a large number of PHP upgrades on Plesk 7.5.4 and have only had problems with PHP5 (SiteBuilder and Horde break).

    [EDIT]

    Use a source RPM for best results. Also, if you have dependencies, try using up2date to fill them.
     
  3. ali_deren

    ali_deren Guest

    0
     
    up2date works?

    Firstly thank you for your help.

    Can i do this upgrade with using up2date?

    Code:
    [root@vps root]# up2date php
    Does it works?

    Also when i write:

    Code:
    up2date -l
    i can not get which version of php that up2date will perform. I am afraid of php5 or the latest version, because of this i couldn't perform an upgrade.

    Thanks.
     
  4. rpawlik

    rpawlik Guest

    0
     
    You will not be able to use up2date to upgrade PHP because the current version released from Redhat is 4.3.2. This should be patched for any security problems from Redhat so if that is the reason for the upgrade, it should already be patched.

    If you would like I can upload some PHP 4.4.4 SRPMS to my site for you and let you know how to compile it(I couldn't find working 4.3.3 RPMs). PHP upgrades from source can get hairy sometimes but I will do my best to help you out :)

    To check what version Redhat is currently supporting you can run:

    up2date --showall | grep -i php

    However, up2date should patch PHP automatically when Redhat releases a new version. Furthermore, if you upgrade PHP, you will have to keep up with new versions that come out and make sure you patch it. You will also need to add PHP to the up2date skip list (so your new install does not get blown away when there is an update). You can do this by running the following:

    up2date --configure

    Then you will select option 20 and add php to the package skip list.
     
  5. ali_deren

    ali_deren Guest

    0
     
    I will be happy, if you put php4.4.4 srpms. I can not find any one.

    Also tell how can i compile it?

    If it is possible, can you guide me while i am perfoming upgrade. We can use instant messenger to communicate. (MSN or Yahoo)

    It is a working server and i can not risk easily. But i need PHP4.3.3 or above for an application.

    Thanks again for your help
     
  6. rpawlik

    rpawlik Guest

    0
     
    I will be glad to help you out. I'll be busy for the next couple of days but once I have the time, I will walk you through doing this.

    If for some reason the upgrade goes bad (it may become hard for me to troubleshoot an error without logging in to troubleshoot) we can always remove the new PHP RPMs we build and use up2date to roll you back to what you had. Also, I may be able to get my hands on some binary RPMs and we can try those.

    If you want to, you can try and install these 4.3.10 RPMs that should work with ES3:

    http://rpm.ramseypawlik.com:8080/php/php-4.3.10-ES3/

    what you will want to do is create a directory in your home dir called php or whatever. Then you can use wget to grab them:

    wget http://rpm.ramseypawlik.com:8080/path/to/rpm


    Once you have them all, try the following to see if there are any errors:

    rpm -Uvh --test *

    If it prepares with no errors, try to install them:

    rpm -Uvh *

    You will then need to restart Apache and test your sites(including Plesk). If everything is still up, you should be good. If you run into a problem, run the following:

    rpm -qa | grep -i php <-- this will list the php rpms

    You will then need to remove the PHP RPMS. Make sure you only remove the newly installed RPMs (Plesk has some packages that have php in the name)

    Once you have all the PHP rpms listed run:

    rpm -e php php-devel .....

    If it complains about removing them, no deps it:

    rpm -e --nodeps php php-devel .....


    Then up2date the old RPMs:

    up2date php php-devel php-mysql .......

    service httpd restart


    This should bring you back to where you were before the upgrade. Let me know how it goes. If you can't get it working, I'll try and walk you through compiling them from source when I can.

    I look forward to hearing how things go for you.
     
  7. ali_deren

    ali_deren Guest

    0
     
    I downloaded rpms.

    I tried to test

    rpm -Uvh --test *

    I got this warning:

    warning: php-4.3.10-RS_SMS.1.i386.rpm: V3 DSA signature: NOKEY, key ID b3bb04f8

    No any error or warning except this warning.

    Is it a factor that doesn't let me to upgrade?

    Sorry for my bad english.

    Thank you.
     
  8. rpawlik

    rpawlik Guest

    0
     
    You can safely ignore that warning. If that is the only message you got, you should be safe in installing the RPMs. Let me know how it goes.
     
  9. ali_deren

    ali_deren Guest

    0
     
    Everything is OK!

    Thank you!

    I think everything is OK. It was successfully upgrading.

    But it had would be better, If i had backup my old php.ini file. But that is not important. I will tune some settings. That's all.

    Thank you again.

    Please dont hesitate, if i can help you any issue.

    Ali
     
  10. ali_deren

    ali_deren Guest

    0
     
    w

    This is the screenshot!

    [​IMG]

    I have just realized on the screenshot. It made a backup for me.
     
  11. rpawlik

    rpawlik Guest

    0
     
    That looks good. You may want to try running a php -m and make sure you don't get any errors. Also, are all of your PHP pages working? If you don't get any errors when running php -m and your sites are working, the install was successful. Hope to hear from you soon.
     
  12. rpawlik

    rpawlik Guest

    0
     
    One other thing, make sure you add PHP to the up2date package skiplist! You don't want your new PHP version to be replaced buy Redhats!
     
  13. nibb@

    nibb@ Guest

    0
     
    Wow, wow, wow. Im looking for a week now for the same thing. Is it actually so easy? My host wanted to charge me 150$ for doing this. I also accidentally updated my plesk 7.5.4 to 8.01 and it broke my server. Its fixed now, but of course php is stil the same. I read about the rocket turtle RPM here and i wanted to do the same thing after reading this post. I did the same think but with a RPM for Plesk i downloaded from Rocket Turtle. I also have php 4.3.2 RHEL3 and i need a new version. I did this:
    rpm -Uvh --test php-4.4.4-1.art.src.rpm

    No errors

    Then i did
    rpm -Uvh php-4.4.4-1.art.src.rpm

    But nothing did happend. I did not installed nothing. Still swhos php 4.3.2 after php -v command.
     
  14. rpawlik

    rpawlik Guest

    0
     
    You are trying to install a source RPM. You will need to do the following:

    rpm -ivh php-whatever.src.rpm

    Then you will need to go to /usr/src/redhat/SPECS.

    Once in the specs directory you should see a file called php.spec or something similar. You will then need to run the following:

    rpmbuild -bb php.spec

    This will compile an RPM from source. You cannot break anything at this stage although the potential for error is high. Building RPMs can be hairy if you have never done it before.

    If you get lucky and everything builds with no errors, you can run:

    cd ../RPMS/i386

    The RPMS you built should be in that directory(there should be several). THEN you can run:

    rpm -Uvh --test *.rpm

    If the test passes go ahead and install the RPMs. You will then need to restart Apache and check your sites. If you run into problems that you can't fix, remove the installed RPMs and use up2date to get you back to what you were running. You may even want to save the list of PHP packages you have installed before doing this and save it in a file:

    rpm -qa | grep -i php >> php.out

    Let me know how it goes. Also, what version of PHP do you need and what OS are you running? I may be able to get you some binary RPMs so you won't have to build them from source.
     
  15. rpawlik

    rpawlik Guest

    0
     
    Ok, I see that you are wanting PHP 4.4.4. Are you on RHEL 3 or RHEL 4? I can get binary RPMs which will make your life a lot easier :p
     
  16. schatje

    schatje Guest

    0
     
    Do you have binary RPM's for Plesk 7.5.4 on FC1 ?

    Thanks,

    Schatje
     
Loading...