1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP and QMail, what is the right setting?

Discussion in 'Plesk for Linux - 8.x and Older' started by ElricM, Dec 17, 2005.

  1. ElricM

    ElricM Guest

    0
     
    I've searched through the forums looking for the answer to this, but haven't quite found it. Mail is working normally on my system, send/receive no problems. Telnet to port 25 or 110 is less than a second.

    I have -Rt0 in /etc/xinetd.d/smtp_psa

    The problem is when sending mail through PHP. It works correctly, but it's slow to make the connection. Like 2 minutes or more for the form to come back. I have the following in php.ini

    sendmail_path = /usr/sbin/sendmail -t -i

    I've also tried

    sendmail_path = /var/qmail/bin/qmail-inject -t -i

    but while that allowed the form to come back quickly, I never received any mail.

    What is the proper sendmail_path for PHP when using Plesk (I'm on 7.5.3) or how can I speed this up? I don't want the user waiting 2 minutes or more for the form to return.

    Thanks for any advice.
     
  2. it-biz

    it-biz Guest

    0
     
    sendmail_path = /var/qmail/bin/qmail-inject
    or
    sendmail_path = /usr/sbin/sendmail -t -i

    Are correct if /usr/sbin/sendmail exists on your system.

    2 minutes for the form to finish seems not related to this setting to my opinion.
     
  3. ElricM

    ElricM Guest

    0
     
    Well they obviously are since only mail sent through PHP is effected. Also, by changing php.ini to

    sendmail_path = /var/qmail/bin/qmail-inject -t -i

    will allow the form to return immediately however no mail is ever received. Changing it back to

    sendmail_path = /usr/sbin/sendmail -t -i

    causes the PHP form to take 2 minutes again and I do receive the email.
     
  4. ElricM

    ElricM Guest

    0
     
    OK, so here's an update:

    If I stop the Dr.Web service, then this is really fast.

    Anybody know how to keep Dr. Web running and speed this up? (Mail sent via a PHP form).

    Thanks for your help.
     
Loading...