1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

***.php is part of Plesk distribution... After update to 9.3

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Jose Rivas, Mar 29, 2010.

  1. Jose Rivas

    Jose Rivas Guest

    0
     
    Hy all,
    I´ve updated last week our plesk instalation from version 8.4 to 9.3 on a FC4 system.
    No I have the problem that the Installation seems to be broken.
    I get several errors like this:
    #!/usr/local/psa/admin/bin/php The file loger.php is part of Plesk distribution. It cannot be run outside of Plesk environment.
    I get this error with several different files.
    I read down the knowledge base on this matter and found this entry en in KB.
    http://kb.odin.com/en/1339
    So I tried reinstalling the License-key my provider has given me, but it really didn’t change much.

    I also read that restarting solved the auth.php3 problem and tried several restarts, it had now effect also.
    Would like to know how I could reinstall this version of plesk or verify my license key.
    Thanks in advance for your help.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Mentioned KB article is for Windows Plesk version. Look at this thread. Maybe it will help.
     
  3. Jose Rivas

    Jose Rivas Guest

    0
     
    Thanks a lot Igor for your quick answer I read through the link and the links included and came to the conclusion to launch the autoinstaller again to see if there where any installation errors related to some unresolved dependencies as suggested in the linked posts.
    I first re-run the updater to see if there are any errors.

    I tried to execute the plesk_getkeyinfo.sh and run into the iskeyprop() error.
    PHP Fatal error: Call to undefined function iskeyprop() in Command line code on line 1
    After some research I found that there is a known solutions for this by updating the autoinstaller.

    I did that, I´ve updated it to this version but the iskeyprop error stays.
    [root@ns27573 psa]# /usr/local/psa/admin/sbin/autoinstaller --version
    Parallels Products Installer 3.5.0 (build at 2009-08-17 16:41)

    [root@ns27573 PSA_9.3.0]# sh /root/psa/PSA_9.3.0/plesk_getkeyinfo.sh
    Key Info v1.0
    PleskLogin
    PleskPassword
    PHP Fatal error: Call to undefined function iskeyprop() in Command line code on line 1


    Note.:
    I remember I had to install a new key after the upgrade, so I wanted to get sure I got it installed.

    Afer further research and had a closer look into the plesk_getinfo.sh script and found out that my active key is the following.
    8 PLSK007XXXXX0006 NULL /etc/psa/psa.key 2010-01-27 21:30:50 false
    But the Key I hopefully installed ended with 8.
    I installed the following key on the panel.
    PLSK.007xxxx.0008

    Is there a manual way to install the License key?
     
  4. Jose Rivas

    Jose Rivas Guest

    0
     
    Find a way to install the key manually with /usr/local/psa/admin/sbin/keymng.

    But still no change, even after restart.
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Seems Plesk is broken now after uncompleted upgrade. Try to run and complete upgrade or contact support team for fixing your broken Plesk.
     
Loading...