1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php mail() not recognised

Discussion in 'Plesk for Linux - 8.x and Older' started by sametch, Dec 23, 2004.

  1. sametch

    sametch Guest

    0
     
    I have just leased a dedicated linux server with plesk 7.5 installed.

    All my sites that use the mail function come up with an error "unrecognised function".

    My host tell me this is a problem with Plesk 7.5 not recognising the sendmail program.

    Please tell me this isn't true and there is a workaround!

    All my perl scripts that use sendmail work fine!
     
  2. phorium

    phorium Guest

    0
     
    I am unable to send mail via php as well, although I'm not getting any errors. It's like the request just goes off into space and no error is logged. mail() was working before the upgrade to 7.5.1, but I haven't been able to figure out why it is no longer working.

    I'm running Suse 9.1
     
  3. phorium

    phorium Guest

    0
     
    i was able to fix this by upgrading the server to php 4.3.10
     
  4. sametch

    sametch Guest

    0
     
    My server appear to be running suse 9.2.

    The people looking after it have spend literally days trying to get to the bottom of it without success. they have even built a new server. From scratch and re-installed all my sites.

    But they are getting nowhere. This is not very good :mad:
     
  5. Cranky

    Cranky Guest

    0
     
    This isn't a plesk problem .. it has to be a PHP or qmail problem. Your provider should have been able to fix this by now, it should never have got as bad as having to restore the entire server - are you sure they know what they're doing?
     
  6. are_eye_see_kay

    are_eye_see_kay Guest

    0
     
    this will sound crazy, but it's worked for me a few times, and I probably got lucky. If something is broken in plesk and you just cant figure it out, check the updater. I've run into issues with qmail, and gon in farting around with it for a few hours, getting myself angry at it, like it cares. Then, I look in the updater, and it shows qmail as having an update, even though I just ran a successful update, and then all of a sudden it worked.


    It probably won't work, but it did for me a couple of times, so it might be worth a shot.
     
  7. sametch

    sametch Guest

    0
     
    I do not know what caused the problem, but the people who ooked after my server rebuilt it using fedora instead of suse and it now works fine.
     
Loading...