• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved PHP not running on subdomain - File Not Found

OlgaKM

Basic Pleskian
I set up a subdomain for testing purposes. After trouble running my scripts, I decided to test if PHP was working using a simple phpinfo script. When I try to request http://subdomain.domain.com/phpinfo.php, I get a 404 File Not Found message. HTML files work fine. Same PHP file on the main domain works fine (as do other PHP files). The PHP handler on the subdomain is nginx + php-fpm, which is the same as the main domain. I tried changing it to Apache + FastCGI, but this made no difference. Looking at the nginx files for both domains, the settings seem to be identical except for the path to the socket file. Both socket files exist with same ownership and permissions.

I have seen a few similar complaints on these forums and elsewhere online, but no steps described helped me. In most of the cases, the problem was resolved by reconfiguring the domain (this didn't help me). I have also tried removing the subdomain and re-creating. This was no help either.

Interestingly, when I click "View the phpinfo() page" from the PHP Settings page, I get "Error: Unable to retrieve information about the PHP configuration."

There are no messages in any of the vhost logs.

I'm completely at a loss. Any ideas for troubleshooting this?
 
Never mind. It is a problem I created for myself by editing the Plesk virtual host templates. As my changes were custom, I don't think explaining what the error was would be helpful here.
 
Back
Top