• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PHP Startup: Unable to load dynamic library - wrong ELF class: ELFCLASS32

pacwebhosting

New Pleskian
Hi

I have installed sitebuilder 4.5 from yum on centos 5.5 x64 and have the following issue:

[root@websitebuilder plesksitebuilder]# sb_config
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php52/lib/php/modules/sitebuilder3.so' - /opt/
php52/lib/php/modules/sitebuilder3.so: wrong ELF class: ELFCLASS32 in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php52/lib/php/modules/sitebuilder3.so' - /opt/
php52/lib/php/modules/sitebuilder3.so: wrong ELF class: ELFCLASS32 in Unknown on line 0
Usage:


Has anyone come across this before?

Thanks

Paul
 
As I am understanding it the sitebuilder3.so file is 32bit while the os is 64bit?

However

[root@websitebuilder updates]# rpm -Uhv *.rpm
Preparing... ########################################### [100%]
package php5sb-5.2.1-10swsoft.x86_64 is already installed
package php5-ioncube-php52-4.5.0-centos5x86_64.08052912.x86_64 is already installed
[root@websitebuilder updates]#

So as I understand it should be 64bit??

Thanks

Paul
 
Back
Top