1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php5-cli vs. php4HELP! removing php5-cli removes psa packages

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by CCHickman, Jan 15, 2010.

  1. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    Hello --

    I'm proud to be the first to post on this forum (laughing).

    I installed PLESK 9.3.0. I use many of the ART RPM packages. Other than removing the atmail1.03 package (which I believe has been corrected) -- I've yet to have problems.

    Until today - I noticed that apache is spawning many processes and being extremely resource intense. I did recently upgraded php to 5.2.12, so I've decided to downgrade and test things out.

    This is where the fun happens --


    [root@metroplex360 packages]# rpm -Uvh php-5.2.9-2.el4.art.i386.rpm php-cli-5.2.9-2.el4.art.i386.rpm php-common-5.2.9-2.el4.art.i386.rpm php-devel-5.2.9-2.el4.art.i386.rpm php-gd-5.2.9-2.el4.art.i386.rpm php-imap-5.2.9-2.el4.art.i386.rpm php-ldap-5.2.9-2.el4.art.i386.rpm php-mbstring-5.2.9-2.el4.art.i386.rpm php-mysql-5.2.9-2.el4.art.i386.rpm php-odbc-5.2.9-2.el4.art.i386.rpm php-pdo-5.2.9-2.el4.art.i386.rpm php-soap-5.2.9-2.el4.art.i386.rpm php-tidy-5.2.9-2.el4.art.i386.rpm php-xml-5.2.9-2.el4.art.i386.rpm
    Preparing... ########################################### [100%]
    file /usr/bin/php-cgi from install of php-cli-5.2.9-2.el4.art conflicts with file from package psa-php4-cgi-4.3.10-2


    Interesting... we have a conflict. My thoughts are: I don't want PHP4-CGI or need it.

    [root@metroplex360 packages]# rpm -e psa-php4-cgi
    error: Failed dependencies:
    php-cgi is needed by (installed) psa-php4-configurator-1.5.1-cos4.build93091230.07.noarch

    [root@metroplex360 packages]# rpm -e psa-php4-cgi psa-php4-configurator
    error: Failed dependencies:
    psa-php-configurator >= 1.5.1 is needed by (installed) psa-9.3.0-cos4.build93091230.07.i586
    psa-php-configurator is needed by (installed) psa-atmail-1.02-cos4.build93091230.07.noarch

    Which means that I cannot remove psa-php-configurator / psa-php4-cgi

    The latest autoinstaller does not allow it to be removed either. Thus, I've removed it:

    [root@metroplex360 ~]# rpm -e --nodeps psa-php4-cgi

    And reinstalled php 5.2.9.

    --

    So in summary -- psa-php4-cgi should be optional and not conflict with php-cli.
     
Loading...