• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

php5-fpm

GenXRoad

Basic Pleskian
Hello, my php5-fpm won't start

/var/log/php5-fpm.log

Code:
[24-Jun-2015 12:04:43] ERROR: No pool defined. at least one pool section must be specified in config file
[24-Jun-2015 12:04:43] ERROR: failed to post process the configuration
[24-Jun-2015 12:04:43] ERROR: FPM initialization failed

how to fix this Problem ?
 
What sort of output:

# ll /etc/sw-engine/pool.d/

Have you tried fix it with bootstrapper repair?
 
Once again - have you tried fix it with bootstrapper repair?
 
yes i did, but plesk works great, only php5-fpm won't start because the error taht no pool is defined....

/etc/php5/fpm/pool.d/www.conf

Code:
# Default www-pool configuration has been disabled by Plesk Panel.
# Pool configuration was saved in '/etc/php5/fpm/pool.d/www.conf.saved_by_psa'.

/etc/php5/fpm/pool.d/www.conf.saved_by_psa do not exist... in /etc/log/php5-fpm.log

Code:
[25-Jun-2015 14:02:10] ERROR: No pool defined. at least one pool section must be specified in config file
[25-Jun-2015 14:02:10] ERROR: failed to post process the configuration
[25-Jun-2015 14:02:10] ERROR: FPM initialization failed

how to solve this Problem, that php5-fpm will run, so that i can run Webpages with nginx/php-fpm Support ?
 
Try to reinstall php-fpm. Remove rpm package and then install it again with autoinstaller.
 
Back
Top