• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PHP5, Plesk8.3 & Horde

R

RooMeat

Guest
Hey guys.
I am looking at upgrading PHP from 4.3.9 to PHP5.
I have heard that this will break Horde webmail.
Is this correct.. and if so.. is there a fix?
 
hi,

i think horde will be the smallest problem... if you have really troubles with horde, you can reinstall it (or upgrade it)


backup your old system :)
 
The smallest problem??
So you would expect bigger problems??
 
I'd recommend installing PHP5 as CGI, so you can have it running alongside PHP4 without the risk of breaking anything.
 
We have got about 500 clients here... If there would be an outage of the webmail for 1 or 2 hours, this wouldn't be a big problem...

I think the biggest problem ist, if all scripts of your clients would work with PHP5.
If you got real troubles with horde, you could enable a 2nd php installation with php 4, and enable this only for horde!

AFAIK php in cgi mode is slowing down the scripts?


best regards
manuel
 
We have got about 500 clients here... If there would be an outage of the webmail for 1 or 2 hours, this wouldn't be a big problem...

I think the biggest problem ist, if all scripts of your clients would work with PHP5.
If you got real troubles with horde, you could enable a 2nd php installation with php 4, and enable this only for horde!

AFAIK php in cgi mode is slowing down the scripts?


best regards
manuel

So you are running php5??

Main sites running scripts are mine anyhow haha.. and they are on the latest phpBB3 which is fine with PHP5
 
Ive got PHP 5.2.5 packages in the atomic channel. The issues you have to be aware of on PHP 4.4.8 and PHP 5.2.5 are that the behavior of php_admin_value is now immutable. Once a value has been set by it, it cannot be changed even if called again. If you dont use php_admin_value in any of your vhost.conf files, then you'll be fine.
 
Back
Top