1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP5 Upgrade Fehler

Discussion in 'Plesk for Linux - 8.x and Older' started by key323, Dec 16, 2006.

  1. key323

    key323 Guest

    0
     
    Hallo,
    nach einem upgrade auf php5 funzt plesk nichtmehr...

    wenn ich eine neuinstallation versuche, kommt:

    The following packages have unmet dependencies:
    php5-mysql: Depends: phpapi-20041225
    php5-mysqli: Depends: phpapi-20041225
    php5-pdo-mysql: Depends: phpapi-20041225
    Depends: php5-common (= 5.1.4-swsoft.1) but 5.2.0-0.dotdeb.3 is to be installed
    php5-pdo-pgsql: Depends: phpapi-20041225
    Depends: php5-common (= 5.1.4-swsoft.1) but 5.2.0-0.dotdeb.3 is to be installed
    php5-pdo-sqlite: Depends: phpapi-20041225
    Depends: php5-common (= 5.1.4-swsoft.1) but 5.2.0-0.dotdeb.3 is to be installed



    ich hoffe mir kann einer helfen...

    achja ich habe debian3.1
     
  2. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    php5-pdo brauchst du bei dotdeb nicht mehr , die sind schon in php5-mysql und so drin....

    ich denke du solltest genauer schreiben was du versuchst...

    ev. hilft uns eine liste deiner packete weiter...

    dpkg -l | grep php
     
  3. Doraemon

    Doraemon Guest

    0
     
    Hi, I have the same problem.
    I have use this command:

    dpkg -l | grep php

    and the system return this:

    ii libphp-adodb 4.52-1sarge1 The 'adodb' database abstraction layer for p
    ii php4 4.4.5-0.dotdeb server-side, HTML-embedded scripting languag
    ii php4-cli 4.4.5-0.dotdeb command-line interpreter for the php4 script
    ii php4-common 4.4.5-0.dotdeb Common files for packages built from the php
    ii php4-curl 4.4.5-0.dotdeb CURL module for php4
    ii php4-domxml 4.4.5-0.dotdeb XMLv2 module for php4
    ii php4-gd 4.4.5-0.dotdeb GD module for php4
    ii php4-imap 4.4.5-0.dotdeb IMAP module for php4
    ri php4-ioncube-l 3.0-dbn31.buil PHP ionCube Loader
    ii php4-mysql 4.4.5-0.dotdeb MySQL module for php4
    ii php4-snmp 4.4.5-0.dotdeb SNMP module for php4
    ii php5-cgi 5.2.1-0.dotdeb server-side, HTML-embedded scripting languag
    ii php5-cli 5.2.1-0.dotdeb command-line interpreter for the php5 script
    ii php5-common 5.2.1-0.dotdeb Common files for packages built from the php
    ii php5-curl 5.2.1-0.dotdeb CURL module for php5
    ii php5-dev 5.2.1-0.dotdeb Files for PHP5 module development
    ii php5-gd 5.2.1-0.dotdeb GD module for php5
    ii php5-gmp 5.2.1-0.dotdeb GMP module for php5
    ii php5-imap 5.2.1-0.dotdeb IMAP module for php5
    ii php5-ioncube 3.1-dbn31.buil PHP ionCube Loader
    ii php5-ldap 5.2.1-0.dotdeb LDAP module for php5
    ii php5-mcrypt 5.2.1-0.dotdeb MCRYPT module for php5
    ii php5-mhash 5.2.1-0.dotdeb MHASH module for php5
    ii php5-mysql 5.2.1-0.dotdeb MySQL module for php5
    rc php5-mysqli 5.2.0-0.dotdeb MySQLi module for php5
    ii php5-odbc 5.2.1-0.dotdeb ODBC module for php5
    rc php5-pdo-mysql 5.2.0-0.dotdeb PDO-MySQL module for php5
    rc php5-pdo-pgsql 5.2.0-0.dotdeb PDO-PostgreSQL module for php5
    rc php5-pdo-sqlit 5.2.0-0.dotdeb PDO-SQLite module for php5
    ii php5-pear 5.2.0-0.dotdeb PEAR - PHP Extension and Application Reposit
    ii php5-pgsql 5.2.1-0.dotdeb PostgreSQL module for php5
    ii php5-pspell 5.2.1-0.dotdeb Pspell module for php5
    ii php5-snmp 5.2.1-0.dotdeb SNMP module for php5
    ii php5-sybase 5.2.1-0.dotdeb Sybase / MS SQL Server module for php5
    ii php5-tidy 5.2.1-0.dotdeb Tidy module for php5
    ri psa-php4-confi 1.1.0-debian3. Plesk configurator for php4


    can you send me if is possible solve the problem?

    thank's a lot.
     
  4. ExarKun

    ExarKun Guest

    0
     
    Uninstall all php5*-Packages,
    install php4-cgi
    install psa-php5-configuriator
    install your php5*-Packages
     
Loading...