Resolved Upgrade to Plesk Onyx 15.5.3 failed because of not authenticatable

Discussion in 'Plesk Onyx' started by Fabs87, Apr 20, 2017 at 4:59 AM.

  1. Fabs87

    Fabs87 New Pleskian

    6
    70%
    Joined:
    Aug 26, 2015
    Messages:
    10
    Likes Received:
    1
    Location:
    Würzburg, Germany
    Hey,

    I am not able to upgrade from Plesk Onyx 17.0.17 to 17.5.3. Upgrade fails and gives me this error-message:

    Code:
    WARNING: The following packages cannot be authenticated!
    mysql-server mysql-community-server mysql-client mysql-community-client
    mysql-common
    Any ideas?

    The whole error-message:

    Code:
    Installation started in background
    Auflösung der Paketabhängigkeiten wird geprüft.
    Pakete werden installiert
    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following packages were automatically installed and are no longer required:
    linux-image-3.13.0-100-generic linux-image-3.13.0-101-generic
    linux-image-3.13.0-103-generic linux-image-3.13.0-105-generic
    linux-image-3.13.0-106-generic linux-image-3.13.0-107-generic
    linux-image-3.13.0-108-generic linux-image-3.13.0-109-generic
    linux-image-3.13.0-110-generic linux-image-3.13.0-112-generic
    linux-image-3.13.0-68-generic linux-image-3.13.0-83-generic
    linux-image-3.13.0-85-generic linux-image-3.13.0-86-generic
    linux-image-3.13.0-87-generic linux-image-3.13.0-88-generic
    linux-image-3.13.0-91-generic linux-image-3.13.0-92-generic
    linux-image-3.13.0-93-generic linux-image-3.13.0-95-generic
    linux-image-3.13.0-96-generic linux-image-3.13.0-98-generic plesk-py27
    plesk-py27-pip plesk-py27-setuptools plesk-py27-virtualenv plesk-wheel-cffi
    plesk-wheel-cryptography plesk-wheel-psutil python-chardet-whl
    python-colorama python-colorama-whl python-distlib python-distlib-whl
    python-html5lib python-html5lib-whl python-pip python-pip-whl
    python-requests-whl python-setuptools-whl python-six-whl python-urllib3-whl
    python-virtualenv
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    plesk-mysql-server
    The following NEW packages will be installed:
    pp17.5.3-bootstrapper sw-engine-cli-2.21
    The following packages will be upgraded:
    plesk-mysql-server
    1 upgraded, 2 newly installed, 0 to remove and 134 not upgraded.
    Need to get 3440 kB of archives.
    After this operation, 13.3 MB of additional disk space will be used.
    Get:1 http://autoinstall.plesk.com/ubuntu/PSA_17.5.3/ trusty/all plesk-mysql-server amd64 17.5.3-ubuntu14.04.build1705170317.16 [758 B]
    Get:2 http://autoinstall.plesk.com/ubuntu/PSA_17.5.3/ trusty/all sw-engine-cli-2.21 amd64 2.21.0-ubuntu1404.201702161518 [3189 kB]
    Get:3 http://autoinstall.plesk.com/ubuntu/PSA_17.5.3/ trusty/all pp17.5.3-bootstrapper amd64 17.5.3-ubuntu14.04.build1705170317.16 [250 kB]
    Fetched 3440 kB in 0s (10.8 MB/s)
    (Reading database ... 168060 files and directories currently installed.)
    Preparing to unpack .../plesk-mysql-server_17.5.3-ubuntu14.04.build1705170317.16_amd64.deb ...
    Unpacking plesk-mysql-server (17.5.3-ubuntu14.04.build1705170317.16) over (17.0.17-ubuntu14.04.build1700161028.14) ...
    Selecting previously unselected package sw-engine-cli-2.21.
    Preparing to unpack .../sw-engine-cli-2.21_2.21.0-ubuntu1404.201702161518_amd64.deb ...
    Unpacking sw-engine-cli-2.21 (2.21.0-ubuntu1404.201702161518) ...
    Selecting previously unselected package pp17.5.3-bootstrapper.
    Preparing to unpack .../pp17.5.3-bootstrapper_17.5.3-ubuntu14.04.build1705170317.16_amd64.deb ...
    Unpacking pp17.5.3-bootstrapper (17.5.3-ubuntu14.04.build1705170317.16) ...
    Setting up plesk-mysql-server (17.5.3-ubuntu14.04.build1705170317.16) ...
    Setting up sw-engine-cli-2.21 (2.21.0-ubuntu1404.201702161518) ...
    Setting up pp17.5.3-bootstrapper (17.5.3-ubuntu14.04.build1705170317.16) ...
    is running
    Stopping sw_engine service... done
    ===> Cumulative APS controller database (apsc) upgrade has been started.
    ===> Cumulative upgrade of APS controller database has been completed.
    ===> Cumulative Plesk database upgrade (revertable stage) has been started.
    ===> Preparing Plesk database upgrade (revertable stage).
    ===> Cumulative upgrade of Plesk database (revertable stage) has been completed.
    ===> Plesk database scheme upgrade has been started.
    Applying migrations from: /opt/psa/bootstrapper/pp17.5.3-bootstrapper/migrations/
    Migration 17.5.0/2016-12-16-10-20-39_change_dns_recs_val_length.php applied
    Migration 17.5.0/2016-12-26-09-56-48_change_dates_default_value.php applied
    ===> Plesk database scheme upgrade has been completed.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    plesk-mysql-server is already the newest version.
    sw-engine-cli-2.21 is already the newest version.
    pp17.5.3-bootstrapper is already the newest version.
    The following packages were automatically installed and are no longer required:
    linux-image-3.13.0-100-generic linux-image-3.13.0-101-generic
    linux-image-3.13.0-103-generic linux-image-3.13.0-105-generic
    linux-image-3.13.0-106-generic linux-image-3.13.0-107-generic
    linux-image-3.13.0-108-generic linux-image-3.13.0-109-generic
    linux-image-3.13.0-110-generic linux-image-3.13.0-112-generic
    linux-image-3.13.0-68-generic linux-image-3.13.0-83-generic
    linux-image-3.13.0-85-generic linux-image-3.13.0-86-generic
    linux-image-3.13.0-87-generic linux-image-3.13.0-88-generic
    linux-image-3.13.0-91-generic linux-image-3.13.0-92-generic
    linux-image-3.13.0-93-generic linux-image-3.13.0-95-generic
    linux-image-3.13.0-96-generic linux-image-3.13.0-98-generic plesk-py27
    plesk-py27-pip plesk-py27-setuptools plesk-py27-virtualenv plesk-wheel-cffi
    plesk-wheel-cryptography plesk-wheel-psutil python-chardet-whl
    python-colorama python-colorama-whl python-distlib python-distlib-whl
    python-html5lib python-html5lib-whl python-pip python-pip-whl
    python-requests-whl python-setuptools-whl python-six-whl python-urllib3-whl
    python-virtualenv
    Use 'apt-get autoremove' to remove them.
    The following packages will be upgraded:
    fail2ban libapache2-mod-aclr2-psa libapache2-mod-fcgid-psa
    libapache2-mod-passenger-plesk libapache2-mod-proxy-psa
    libapache2-mod-sysenv-psa libpam-plesk mysql-client mysql-common
    mysql-community-client mysql-community-server mysql-server passenger
    passenger-dev passenger-native-libs plesk-base plesk-completion
    plesk-config-troubleshooter plesk-core plesk-dns-bind-driver plesk-dovecot
    plesk-dovecot-core plesk-dovecot-imap-driver plesk-dovecot-pigeonhole
    plesk-engine plesk-fail2ban-configurator plesk-l10n plesk-libmyodbc
    plesk-lmlib plesk-mail-pc-driver plesk-management-node plesk-php70
    plesk-php70-bcmath plesk-php70-cli plesk-php70-dba plesk-php70-enchant
    plesk-php70-fpm plesk-php70-gd plesk-php70-imagick plesk-php70-imap
    plesk-php70-intl plesk-php70-ldap plesk-php70-mbstring plesk-php70-mcrypt
    plesk-php70-mysql plesk-php70-odbc plesk-php70-opcache plesk-php70-pdo
    plesk-php70-pear plesk-php70-pgsql plesk-php70-process plesk-php70-pspell
    plesk-php70-snmp plesk-php70-soap plesk-php70-tidy plesk-php70-xml
    plesk-php70-xmlrpc plesk-php71 plesk-php71-bcmath plesk-php71-cli
    plesk-php71-dba plesk-php71-enchant plesk-php71-fpm plesk-php71-gd
    plesk-php71-imap plesk-php71-intl plesk-php71-ldap plesk-php71-mbstring
    plesk-php71-mcrypt plesk-php71-mysql plesk-php71-odbc plesk-php71-opcache
    plesk-php71-pdo plesk-php71-pear plesk-php71-pgsql plesk-php71-process
    plesk-php71-pspell plesk-php71-snmp plesk-php71-soap plesk-php71-tidy
    plesk-php71-xml plesk-php71-xmlrpc plesk-release plesk-roundcube
    plesk-service-node-utilities plesk-skins plesk-web-hosting plesk-wp-upgrade
    psa psa-autoinstaller psa-drweb-configurator psa-firewall psa-horde psa-imp
    psa-ingo psa-kronolith psa-libxml-proxy psa-locale-base-en-us
    psa-mail-driver-common psa-mnemo psa-passwd psa-php5-configurator
    psa-phpfpm-configurator psa-phpmyadmin psa-phppgadmin psa-proftpd
    psa-pylibplesk psa-turba psa-updates psa-vhost psa-zendframework sw-collectd
    sw-cp-server sw-engine sw-librrd sw-nginx sw-rrdtool
    117 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.
    Need to get 165 MB of archives.
    After this operation, 2565 kB of additional disk space will be used.
    WARNING: The following packages cannot be authenticated!
    mysql-server mysql-community-server mysql-client mysql-community-client
    mysql-common
    E: There are problems and -y was used without --force-yes
    Plesk is down, performing full restart.
    Starting sw_engine service... done
    Starting sw_cp_server service... already started
    Starting mysql service... already started
    Starting named service... already started
    Starting mailer service... already started
    Starting spamfilter service... not installed
    Starting drweb service... unused
    Starting tomcat service... not installed
    Starting apache service... already started
    Starting xinetd service... already started
    Error: Ein Fehler ist aufgetreten bei dem Versuch, Pakete zu installieren.
    Achtung! Ihre Software ist vielleicht nicht betriebsbereit.
    Bitte kontaktieren Sie den technischen Produktsupport.
     
  2. Fabs87

    Fabs87 New Pleskian

    6
    70%
    Joined:
    Aug 26, 2015
    Messages:
    10
    Likes Received:
    1
    Location:
    Würzburg, Germany
    Ok, it's done.

    The problem was an expired key for MySQL. The problem is described here. I found the problem while I was trying to update the packages manually via ssh "apt-get update". If you want to know, if you have an expired key, too, run
    Code:
    apt-key list
    in your terminal.

    If your key is expired too, run:
    Code:
    apt-key adv --keyserver keys.gnupg.net --recv-keys 5072E1F5
    After this, you can run
    Code:
    apt-get update
    to update your packages.

    Finally start the update-process via the Plesk Installer (Webinterface).
     
  3. UFHH01

    UFHH01 Platinum Pleskian Plesk Guru

    40
    64%
    Joined:
    Jun 11, 2013
    Messages:
    4,919
    Likes Received:
    1,017
    Location:
    Hamburg / Germany
    Hi Fabs87,

    Code:
    WARNING: The following packages cannot be authenticated!
    mysql-server mysql-community-server mysql-client mysql-community-client
    mysql-common
    due to the fact that Plesk doesn't ship any MySQL - packages for Debian/Ubuntu, pls. consider to post non-Plesk-related issues at the forum:

     
  4. AdelM

    AdelM Basic Pleskian

    19
     
    Joined:
    Aug 14, 2010
    Messages:
    39
    Likes Received:
    0
    Thanks Fabs87 for sharing the solution

    I had the same problem after mysql upgrade to 5.6

    Problem is resolved for me too.
     
Loading...