1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Php5?

Discussion in 'Plesk for Linux - 8.x and Older' started by zcwd, Apr 3, 2006.

  1. zcwd

    zcwd Guest

    0
     
    Is PHP5 come standard on this version? If not can it be loaded easily without messing everything up?
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Ive got PHP 5 rpms in my [atomic-testing] channel, and 5.1 in [atomic-bleeding] now. For rh9, 3es/centos3, 4es/centos4, fc2, fc3, and fc4.
     
  3. zcwd

    zcwd Guest

    0
     
    I'm guessing that means it doesn't come stock then... Atomic, does your package allow for safe future upgrades? (And thanks for all of your superb work for us Plesk users) We've had very few issues with Plesk. The only times we have had issues is when we are pushing it past what its been built on.
     
  4. zcwd

    zcwd Guest

    0
     
    Also, do you have anything in the pipe for Redhat ES3 and ES4?
     
  5. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Yep, for rhel3/rhel4 users, you can use the centos3 or 4 packages.
     
  6. zcwd

    zcwd Guest

    0
     
    Just be sure on this...

    Atomic, does your package allow for safe future upgrades?
     
  7. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    They do indeed
     
  8. epiweb

    epiweb Guest

    0
     
    atomic first of all thanks for your excellent help with yum and your RPM builds

    i'm new to yum and i am having trouble with dependancies. i'm trying to update php4 to php5 on fedora core 3 with plesk 8.0

    i have downloaded the php-5.1.2-4.3.rhfc2.art.i386.rpm file and i am trying to run it off my hard drive

    by command

    yum -c ../php5.yum install php-5.1.2-4.3.rhfc2.art.i386.rpm

    i get the message
    --- message
    Error: Missing Dependency: php = 4.4.2-3.rhfc3.art is needed by package php-imap
    Error: Missing Dependency: php = 4.4.2-3.rhfc3.art is needed by package php-mbstring3
    Error: Missing Dependency: php = 4.4.2-3.rhfc3.art is needed by package php-mysql
    Error: Missing Dependency: php = 4.4.2-3.rhfc3.art is needed by package php-pgsql
    Error: Missing Dependency: php = 4.4.2-3.rhfc3.art is needed by package php-domxml
    Error: Missing Dependency: php = 4.3.11-2.8 is needed by package php-gd
    --- end message

    i am using a custom config file from your website (modified because some of the links didnt work?)
    --- php.yum file
    # ite for RHEL3, and CentOS3 users, replace $releasever with 3ES
    # Note for RHEL4, and CentOS4 users, replace $releasever with 4ES

    # THIS CHANNEL CONTAINS MY PSA COMPATIBLE RPMS (php, mysql, qmail-scanner, etc)
    [atomic]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/art/3/

    [atomic-app-vault]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA App Vault RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/app-vault/

    # SW-Soft Channels
    [psa-7.5]
    name=Atomic Rocket Turtle - $releasever - SW-Soft PSA 7.5 RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/psa-7.5/3/


    # Update mirrors for Fedora, Fedoralegacy, and CentOS 3/4
    [base]
    name=Atomic Rocket Turtle - $releasever - Base OS RPMS mirror
    baseurl=http://3es.atomicrocketturtle.com/3rd-party/base/3/

    [updates]
    name=Atomic Rocket Turtle - $releasever - OS Update RPMS mirror
    baseurl=http://3es.atomicrocketturtle.com/3rd-party/updates/3/

    # up2date users (RHEL3/4)
    # For up2date configurations modify /etc/sysconfig/rhn/sources file, replacing CHANGEME with 3ES for RHEL3 or 4ES for RHEL4 systems.

    # Atomic RPMS
    yum atomic http://3es.atomicrocketturtle.com/atomic/art/3/

    # SW-Soft PSA 7.0.x RPMS
    yum atomic-psa7 http://3es.atomicrocketturtle.com/atomic/psa7/3/

    # SW-Soft PSA 7.1.x RPMS
    yum atomic-psa71 http://3es.atomicrocketturtle.com/atomic/psa71/3/

    # SW-Soft PSA 7.5.x RPMS
    yum atomic-psa75 http://3es.atomicrocketturtle.com/atomic/psa75/3/
    --- end php.yum file

    Obviously yum is looking for php.4.4.2. I thought with the config file it would automatically pick it up from your server? I also downloaded it to my hard drive in the working directory

    Any help is very appreciated !
     
  9. epiweb

    epiweb Guest

    0
     
    Ok i moved this further by adding the bleeding channel to the config file

    --- extra lines in php5.yum
    [atomic-bleeding]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic-bleeding/art/3/
    -- end extra lines in php5.yum

    Now i only get this message
    --- message
    Error: Missing Dependency: php = 4.4.2-3.rhfc3.art is needed by package php-domxml
    --- end message

    I take it i need to include another channel and everything should be great ?

    Nope I needed to uninstall php-domxml. Hope this helps someone !
    Just be careful guys this broke my plesk 8.0... still trying to fix...
    for some reawson the modules_bf1942server table needed a hack after this install. I just set the defaults on one of the fields and no worries
     
  10. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    yeah that package is based on the FC5 design, so if anyone else here has run PSA on FC5 their debugging/tips will be valid for anyone using the atomic-bleeding packages.

    Thanks for the update!
     
  11. cuppett

    cuppett Guest

    0
     
    Horde seems to break under PHP5

    When upgrading from PHP4 to PHP5, it appears Horde has some problems. Horde runs under the production webserver, not the Plesk webserver.

    Here is a bug and responses from Horde:

    http://bugs.horde.org/ticket/?id=3747

    They indicate Plesk packages a modified version of Horde and that base Horde and IMP work just fine under PHP 5.

    The errors in the Plesk version of Horde seem to all take the form:

    PHP Fatal error: Cannot use object of type DB_mysql as array in /usr/share/psa-horde/lib/Horde/DataTree.php
     
  12. chillax

    chillax Guest

    0
     
    I had this issue with the version of Horde that came with 7.5.4 and PHP5 (specifically when I was trying to open a message that I had previously replied to) but that issue does not exist with 8.0.0 for me.
     
  13. JohnB@

    JohnB@ Guest

    0
     
    Hi All:

    Trying to upgrade to PHP 5 using atomic's "atomic-bleeding" RPMs via yum worked after I uninstalled PHP4 and php-domxml.

    However, same as 'epiweb' reported here, I got this error when trying to run a general "yum update" for all packages to the "atomic-bleeding" stage:
    ---------
    Error: Missing Dependency: php = 4.4.2-3.rhel4.art is needed by package php-domxml
    ----------

    This is on a CentOS 4.3 system.

    In another thread someone suggested to put the PHP5 module into the Apache module folder to solve this. What is the name of the PHP5 module??

    ALSO .. when I try upgrading e.g. "frontpage" using the command "yum update frontpage" I get this kind of error:
    --------------
    Package frontpage-5.0-72psa.rhel4.i586.rpm is not signed
    --------------
    Same with most other packages. What is this, how to solve this?

    John
     
  14. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You'll probably need to rip out your old php install out before trying php 5.1.

    On your second question, you'll need to turn the gpgcheck off for the psa archive, since they dont sign their packages.
     
  15. Redah

    Redah Guest

    0
     
    I'm having the following problem when I added the 'bleeding' repository to Yum and ran yum update:

    You don't have a php-pear package? To be honest, I'm not sure why I have it, afaik it came installed with either FC4 (although I cleaned out alot of useless RPMs), or it came with the PLESK 8.0 auto-installer.

    So, should I remove this? You don't appear to have php-pear for other distributions either, as far as I could see...

    *edit * Apparently PLESK installed this ... So I assume I shouldn't remove it. Is there a reason you don't have a pear package?
     
  16. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Because even I havent run packages in atomic-bleeding :p. You're effectively in my CVS tree. Im tempted to rename the art tag on those packages to: dontrunmeeverforanyreasonwhatsoeveryouhavebeenwarned :p

    All joking aside, thanks a lot for testing these out for me, theres no way I'd have the time to run down these issues without your help. I might not be able to assist you on getting this working right away, but I absolutely add your comments to my notes for further debugging. I really couldn't make some of these extreme modifications work without the support of those folks out there willing to try out untested packages like this.
     
  17. Redah

    Redah Guest

    0
     
    What would really interest me, and I presume interests other people as well, is if there's some way you could keep all applications used by PLESK up-to-date in your archives. I'd even pay for an subscription to that.

    What I mean by that is: I've currently got FC4 installed, because that's the highest FC version PLESK supports. I've updated PHP and MySQL to your versions (because FC4 doesn't have newer packages yet), but there are essential things missing that PLESK uses that I'd like to see updated, e.g.: Apache, Bind, ProFTPd (they're at version 1.3.0 now whilst 1.2.10 is still installed by default), which in turn requires OpenSSL, etc.

    To be honest, I haven't looked into the amount of work that would be involved in that, but these are applications that are pretty essential and would be terribly to have 'left behind'. Perhaps some sort of subscription model would get you more motivated on something like this ;)
     
  18. JohnB@

    JohnB@ Guest

    0
     
    Hi !

    I posted earlier in this thread.... still can't solve the yum installer problem. Still get this:

    -----------
    Error: Missing Dependency: php = 4.4.2-3.rhel4.art is needed by package php-domxml
    -----------

    I used "rpm -qa" for a list of all RPMs but cannot find any remaining hint to PHP 4. I cannot upgrade psa and many other packages because of this error -- although PHP is at version 5.1.2.

    php-domxml is NOT installed -- I checked.
    Anyone has a clue why this is still happening?

    John
     
  19. phatPhrog

    phatPhrog Guest

    0
     
    You're not alone in this. I spent several hours installing CentOS and PSA only to find I couldn't use the updater.

    It won't install/update the backup utility, psa-api or other apps.

    Keep telling me:

    ERROR: Can't add to black list product package psa-api

    I found another post concerning installing/updating php-domxml and php-mbstring and the message returned on that is the packages are up-to-date.

    Using both yum and up2date, get the same result.

    Unfortunately, I had to restore FC4/Plesk 8 so I could get my server back online.
     
  20. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    In reference to keeping the box updated from one source (ie yum), that is was the idea of the project, and until around PSA 7.1 it worked like that. Unfortunately PSA itself has since become more modular so I've had to work around that, with other "mule" rpms, like atomic-psa (which needs work).
     
Loading...