1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Please Help

Discussion in 'Plesk for Linux - 8.x and Older' started by nibb@, May 20, 2005.

  1. nibb@

    nibb@ Guest

    0
     
    Apache fails everytime i try to restart. I has to do something with my vhost_ssl.conf

    Apache says:
    httpd -k start
    Syntax error on line 1 of /home/httpd/vhosts/domain.com/conf/vhost_ssl.conf:
    <VirtualHost> cannot occur within <VirtualHost> section

    Here is what my vhost_ssl.conf looks:
    <VirtualHost 67.18.121.000:443>
    ServerName domain.com
    ServerAlias www.domain.com
    UseCanonicalName Off
    SuexecUserGroup domain psacln
    ServerAdmin weiterer@mail.com
    DocumentRoot /home/httpd/vhosts/domain.com/httpsdocs
    CustomLog /home/httpd/vhosts/domain.com/statistics/logs/access_ssl_log combined
    ErrorLog /home/httpd/vhosts/domain.com/statistics/logs/error_ssl_log
    <IfModule mod_userdir.c>
    UserDir /home/httpd/vhosts/domain.com/web_users
    </IfModule>
    ScriptAlias /cgi-bin/ /home/httpd/vhosts/domain.com/cgi-bin/
    Alias /plesk-stat /home/httpd/vhosts/domain.com/statistics/
    Alias /webstat /home/httpd/vhosts/domain.com/statistics/webstat
    Alias /webstat-ssl /home/httpd/vhosts/domain.com/statistics/webstat-ssl
    Alias /ftpstat /home/httpd/vhosts/domain.com/statistics/ftpstat
    Alias /anon_ftpstat /home/httpd/vhosts/domain.com/statistics/anon_ftpstat
    SSLEngine on
    SSLVerifyClient none
    SSLCertificateFile /usr/local/psa/var/certificates/certXUcYmQJ
    SSLCACertificateFile /usr/local/psa/var/certificates/cert-5ZjyLT
    <Directory /home/httpd/vhosts/domain.com/httpsdocs>
    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>
    </IfModule>
    <IfModule mod_perl.c>
    <Files ~ (\.asp$)>
    SetHandler perl-script
    PerlHandler Apache::ASP
    PerlSetVar Global /tmp
    </Files>
    </IfModule>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_value open_basedir "/home/httpd/vhosts/domain.com/httpsdocs:/tmp"
    </IfModule>
    <IfModule mod_python.c>
    <Files ~ (\.py$)>
    SetHandler python-program
    PythonHandler mod_python.cgihandler
    </Files>
    </IfModule>
    SSLRequireSSL
    Options +Includes +ExecCGI
    </Directory>
    <Directory "/home/httpd/vhosts/domain.com/statistics">
    AuthType Basic
    AuthName "EstadÃ_sticas de Dominio"
    AuthUserFile /home/httpd/vhosts/domain.com/pd/d..plesk-stat
    require valid-user
    </Directory>
    Alias "/error_docs" "/home/httpd/vhosts/domain.com/error_docs"
    ErrorDocument 400 /error_docs/bad_request.html
    ErrorDocument 401 /error_docs/unauthorized.html
    ErrorDocument 403 /error_docs/forbidden.html
    ErrorDocument 404 /error_docs/not_found.html
    ErrorDocument 500 /error_docs/internal_server_error.html
    </VirtualHost>
     
  2. Jason Lee

    Jason Lee Guest

    0
     
    I don't see anything in that vhost_ssl.conf that should be there. that all should be located in /home/httpd/vhosts/domain.com/conf/ttpd.include

    the only items you place in vhost.conf or vhost_ssl.conf is the custom modifications to that vhost not the actual vhost declairation itself. For example mine contains...

    Code:
    <Directory "/home/httpd/vhosts/domain.tld/httpsdocs/subfolder/">
    php_admin_flag safe_mode 0
    </Directory>
    <Directory "/home/httpd/vhosts/domain.tld/httpsdocs">
    php_admin_value output_handler ob_gzhandler
    </Directory>
    Hopefully you understand what I'm trying to say.
     
  3. nibb@

    nibb@ Guest

    0
     
    So what part of that should be there of my ssl? I mean looking at my, what do you think it should look? Yes i think there are directives that should not be there, but o dont now what to leave.
     
  4. Jason Lee

    Jason Lee Guest

    0
     
    There doesn't apear to be anything in there that should be left. All of that should already be located in the httpd.include
     
  5. nibb@

    nibb@ Guest

    0
     
    I just left the file blank, now the apache started. The think is maybe plesk is filling the file itself. not me.
     
Loading...