1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10.1.1 managing PHP

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by 01i, Mar 21, 2011.

  1. 01i

    01i Guest

    0
     
    Hi,

    I have recently decided to consolodate my various websites onto a single more power VPS.

    My new VPS came with Parallels Infrastructure Manager (I'm not entirely certain how to tell which version) and Plesk 10.1.1.

    Previously I have always managed everything from the shell. Having a GUI is nice, but I'm struggling to replicate functionality I'm used to having.

    Initially I added all of the available container applications in Infrastructure Manager.

    These included:

    pp10
    pp10-mailman
    pp10-migration
    pp10-panel-addons
    pp10-qmail
    pp10-spamassassin
    p10-watchdog
    pp10-webhosting-addons
    pp10-webmail
    pp10-vps-optimized

    I then started to put together a couple of containiners and started to add my various websites into Plesk.

    I have managed to get my head around most things, except for my PHP installation.

    According to phpinfo I am using FastCGI and it is processing ini files from /etc/php5/cgi and /etc/php5/cgi/conf.d

    However, if I edit php.ini to change my error reporting settings, the settings dont change. I also tried editing the php.ini file in /opt/psa/admin/conf but according to phpinfo that file's not included, and if i edit the error reporting settings, it still doesnt change anything when i restart apache2.

    I also wish to switch from FastCGI to module, but cannot figure that out too. I have learned that the vps-optimised module took away my ability to use PHP in any mode other than cgi, so disabled that in infrastructure manager.

    The only info I can find about changing from CGI to Module is using the virtualhost settings for windows servers only. Likewise, anything I google relating to changing my PHP error settings, bring up windows only features.

    So I have two questions.

    Firstly, how can I switch from FastCGI to Module.

    Secondly, how can I change PHP so that it actually stops giving me deprecated warnings.

    On an unrelated note.

    Some of my sites require multiple databases. I installed a second copy of phpmyadmin with apt-get and set up a symbolic link to enable me to access it and actually managed multiple databases from a single account.

    This works, but it'd be nice to know if there was a better way of doing it, that enables me to have a single installation of phpmyadmin on the server

    The PHP questions are more important to know the answers though, as my phpmyadmin workaround is functional
     
  2. MatthewTLS

    MatthewTLS Guest

    0
     
    I had an issue with using PHP over FastCGI, as FastCGI seems to be Plesk's default option (annoying!). The only way I could figure out how to resolve this issue was to:

    Login to Admin Panel as Admin.
    Under Hosting Services, click on Service Plans
    Select the Service Plan that you are using (i.e. my websites all use the default Gold Hosting service plan)
    Click on the Hosting Parameters tab
    Under the Scripting section next to Run PHP as, select the drop down and select Apache Module

    Good luck!
     
  3. 01i

    01i Guest

    0
     
    Matthew, thanks for the advice, but alas it's not as simple as changing a dropdown.

    I am running Plesk 10.1.1 on an ubuntu VPS. When logged in as admin I have home, users, mail, websites & domains, applications, statistics, server and webspaces.

    There is no 'hosting services' nor any 'service plans' options. Not under Websites and Domains, nor under Server

    I can modify when PHP is enabled or disabled on a website or webspace context, but dont have an option to select how php runs.
     
  4. MatthewTLS

    MatthewTLS Guest

    0
     
    Ah, you are logging in via the Customer Portal. Unfortunately, you won't have the option to change if you use FastCGI or Apache Module. That is something your Plesk Administrator or VPS admin will have to change for you on their end.
     
  5. 01i

    01i Guest

    0
     
    I'm logging in via the URL i was provided.

    I dont have a plesk or vps admin, I have root access on my VPS.

    Any idea what the default port for the admin interface is?
     
  6. MatthewTLS

    MatthewTLS Guest

    0
     
    it depends on your account settings. i have setup Plesk here at our location and there is an administrative back-end that i connect to via https://<server-ip>:8443

    i have a different set of credentials for the admin login. the admin login allows me to setup my users and grant them permissions, my customers see what you have described to me. sounds like you need to have a conversation with the people who setup and host your VPS. the Plesk Panel comes with two parts the admin console and the customer portal. did you install Plesk from the command line on your Virtual Private Server or was it setup for you by the host that provides your VPS?
     
  7. 01i

    01i Guest

    0
     
    It came pre-installed on the VPS.

    I'll send a support ticket
     
  8. MatthewTLS

    MatthewTLS Guest

    0
     
    I hate to leave you empty handed, but I believe that may be your only solution. Let me know how it goes and good luck! :)
     
  9. MatthewTLS

    MatthewTLS Guest

    0
     
    I just created a faux user account on my system ... follow these steps and see if it'll let you change your PHP option to Apache Module:

    Login and click on Websites & Domains
    Scroll to the bottom of the screen and click on your domain name.
    The page that loads (for me) then gives me the option to select between FastCGI and Apache Module
     
  10. 01i

    01i Guest

    0
     
    That was the first place I looked.

    Dont have the option listed in there.

    We'll see what my host comes back with
     
  11. 01i

    01i Guest

    0
     
    In case anybody ends up looking at this thread with a similar problem in the future.

    My server was configured in poweruser mode. This changes the admin GUI into something that combines the customer GUI and business GUI, and gets rid of features like hierachical users, subscriptions and hosting plans.

    Over SSH I navigated to /opt/psa/bin and ran ./poweruser --off

    I now have the features I was missing

    http://download1.parallels.com/Ples...e/plesk-unix-cli/index.htm?fileName=66571.htm
     
Loading...