1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10.2.2 -> 10.4.4 Update broken

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by thE_iNviNciblE, Mar 25, 2012.

  1. thE_iNviNciblE

    thE_iNviNciblE Guest

    0
     
    hello,


    output of my parallels-installation-log...

    how could i fix these errors?

    ----------------------------------------------------------------------------------------

    Installation started in background

    Getting bootstrapper packages to installation list:
    Following bootstrapper packages will be installed: pp10.13.4-bootstrapper-10.13.4-debian5.0.build1013111102.18.amd64
    ----------------

    Getting packages to installation list:
    skip keypackage 'php5-5.2.6.dfsg.1-1+lenny13.all' from component phpgroup - same or newer version of this package is already installed (in system php5-5.2.6.dfsg.1-1+lenny13.all)
    autoinstaller: read output of apt-cache policy psa-mail-pc-driver 2>/dev/null with popen
    autoinstaller: pclose OK
    Package psa-mail-pc-driver with version '1.0.0-debian5.0.build92091210.11' is available from apt
    skip keypackage 'postfix-2.5.5-1.1+lenny1.amd64' from component postfix - same or newer version of this package is already installed (in system postfix-2.5.5-1.1+lenny1.amd64)
    skip keypackage 'samba-2:3.2.5-4lenny15.amd64' from component psa-fileserver - same or newer version of this package is already installed (in system samba-2:3.2.5-4lenny15.amd64)
    skip keypackage 'mailman-1:2.1.11-11+lenny2.amd64' from component mailman - same or newer version of this package is already installed (in system mailman-1:2.1.11-11+lenny2.amd64)
    Following packages will be installed: pp10.13.4-bootstrapper-10.13.4-debian5.0.build1013111102.18.amd64 libapache2-mod-fcgid-psa-2.3.6-11081018.amd64 libpam-plesk-10.13.4-debian5.0.build1013111102.18.amd64 plesk-base-10.13.4-debian5.0.build1013111102.18.amd64 plesk-core-10.13.4-debian5.0.build1013111102.18.amd64 plesk-l10n-10.13.4-debian5.0.build1013111102.18.all plesk-skins-10.13.4-11110218.all psa-10.4.4-debian5.0.build1013111102.18.amd64 psa-awstats-configurator-10.13.4-debian5.0.build1013111101.14.all psa-locale-base-en-us-10.13.4-debian5.0.build1013111102.14.all psa-logrotate-3.7-debian5.0.build1013111101.14.amd64 psa-mod-fcgid-configurator-2.0.0-debian5.0.build1013111101.15.amd64 psa-proftpd-1.3.3e-debian5.0.build1013111101.14.amd64 psa-pylibplesk-10.13.4-debian5.0.build1013111102.18.amd64 psa-updates-10.4.4-debian5.0.build1013111101.14.all psa-vhost-10.13.4-debian5.0.build1013111101.14.all psa-autoinstaller-3.11.0-111102.17.amd64 psa-migration-agents-10.13.4-debian5.0.build1013111102.18.amd64 psa-migration-manager-10.13.4-debian5.0.build1013111102.18.amd64 psa-health-monitor-10.13.4-debian5.0.build1013111101.15.all sw-collectd-4.9.1-11080119.amd64 sw-librrd-1.4.2-11080119.amd64 sw-rrdtool-1.4.2-11080119.amd64 pp-sitebuilder-10.4.4-36793.11110312.all pp-sitebuilder-default-templates-10.4.4-36793.11110312.all pp-sitebuilder-skins-10.4.4-36793.11110312.all psa-php5-configurator-1.6.1-debian5.0.build1013111101.15.amd64 libapache2-mod-bw-0.8-11091218.amd64 psa-tomcat-configurator-10.13.4-debian5.0.build1013111101.14.all psa-rubyrails-configurator-1.1.6-debian5.0.build1013111101.14.amd64 psa-coldfusion-support-10.13.0-debian5.0.build1013110801.18.all psa-miva-1:5.06-debian5.0.build1013111101.14.amd64 plesk-mail-pc-driver-10.13.4-debian5.0.build1013111102.18.amd64 psa-courier-imap-3.0.8-debian5.0.build1013111101.14.amd64 psa-mail-driver-common-10.13.4-debian5.0.build1013111102.18.amd64 psa-mail-pc-driver-1.0.0-debian5.0.build92091210.11 psa-firewall-10.13.4-debian5.0.build1013111102.18.amd64 psa-vpn-10.13.4-debian5.0.build1013111102.18.amd64 psa-fileserver-10.13.4-debian5.0.build1013111102.18.amd64 sshterm-0.2.2-10.11080119.all psa-watchdog-10.13.4-debian5.0.build1013111102.18.amd64 psa-mailman-configurator-10.13.4-debian5.0.build1013111102.18.amd64 psa-kav8-8.0.3-0.303893.all psa-spamassassin-10.13.4-debian5.0.build1013111102.18.amd64 psa-backup-manager-10.13.4-debian5.0.build1013111102.18.amd64 psa-ftputil-1:2.1.1-1.11080119.all psa-libxml-proxy-2.7.8-0.301910.amd64 psa-horde-3.3.10-debian5.0.build1013111101.14.all psa-imp-4.3.9-debian5.0.build1013111101.14.all psa-ingo-1.2.5-debian5.0.build1013111101.14.all psa-kronolith-2.3.5-debian5.0.build1013111101.14.all psa-mimp-1.1.3-debian5.0.build1013110801.18.all psa-mnemo-2.2.4-debian5.0.build1013111101.14.all psa-passwd-3.1.3-debian5.0.build1013111101.14.all psa-turba-2.3.5-debian5.0.build1013111101.14.all
    ----------------
    Auflösung der Paketabhängigkeiten wird geprüft.
    autoinstaller: read output of DEBIAN_FRONTEND=noninteractive LANG=C apt-get --assume-yes --show-upgraded --purge --list-cleanup --no-reinstall -o Dpkg::eek:ptions::=--force-confdef -o Dpkg::eek:ptions::=--force-confold -o Acquire::Retries=3 -o APT::Get::AllowUnauthenticated=true -t 'lenny*' --just-print install pp10.13.4-bootstrapper=10.13.4-debian5.0.build1013111102.18 libapache2-mod-fcgid-psa=2.3.6-11081018 libpam-plesk=10.13.4-debian5.0.build1013111102.18 plesk-base=10.13.4-debian5.0.build1013111102.18 plesk-core=10.13.4-debian5.0.build1013111102.18 plesk-l10n=10.13.4-debian5.0.build1013111102.18 plesk-skins=10.13.4-11110218 psa=10.4.4-debian5.0.build1013111102.18 psa-awstats-configurator=10.13.4-debian5.0.build1013111101.14 psa-locale-base-en-us=10.13.4-debian5.0.build1013111102.14 psa-logrotate=3.7-debian5.0.build1013111101.14 psa-mod-fcgid-configurator=2.0.0-debian5.0.build1013111101.15 psa-proftpd=1.3.3e-debian5.0.build1013111101.14 psa-pylibplesk=10.13.4-debian5.0.build1013111102.18 psa-updates=10.4.4-debian5.0.build1013111101.14 psa-vhost=10.13.4-debian5.0.build1013111101.14 psa-autoinstaller=3.11.0-111102.17 psa-migration-agents=10.13.4-debian5.0.build1013111102.18 psa-migration-manager=10.13.4-debian5.0.build1013111102.18 psa-health-monitor=10.13.4-debian5.0.build1013111101.15 sw-collectd=4.9.1-11080119 sw-librrd=1.4.2-11080119 sw-rrdtool=1.4.2-11080119 pp-sitebuilder=10.4.4-36793.11110312 pp-sitebuilder-default-templates=10.4.4-36793.11110312 pp-sitebuilder-skins=10.4.4-36793.11110312 psa-php5-configurator=1.6.1-debian5.0.build1013111101.15 libapache2-mod-bw=0.8-11091218 psa-tomcat-configurator=10.13.4-debian5.0.build1013111101.14 psa-rubyrails-configurator=1.1.6-debian5.0.build1013111101.14 psa-coldfusion-support=10.13.0-debian5.0.build1013110801.18 psa-miva=1:5.06-debian5.0.build1013111101.14 plesk-mail-pc-driver=10.13.4-debian5.0.build1013111102.18 psa-courier-imap=3.0.8-debian5.0.build1013111101.14 psa-mail-driver-common=10.13.4-debian5.0.build1013111102.18 psa-mail-pc-driver psa-firewall=10.13.4-debian5.0.build1013111102.18 psa-vpn=10.13.4-debian5.0.build1013111102.18 psa-fileserver=10.13.4-debian5.0.build1013111102.18 sshterm=0.2.2-10.11080119 psa-watchdog=10.13.4-debian5.0.build1013111102.18 psa-mailman-configurator=10.13.4-debian5.0.build1013111102.18 psa-kav8=8.0.3-0.303893 psa-spamassassin=10.13.4-debian5.0.build1013111102.18 psa-backup-manager=10.13.4-debian5.0.build1013111102.18 psa-ftputil=1:2.1.1-1.11080119 psa-libxml-proxy=2.7.8-0.301910 psa-horde=3.3.10-debian5.0.build1013111101.14 psa-imp=4.3.9-debian5.0.build1013111101.14 psa-ingo=1.2.5-debian5.0.build1013111101.14 psa-kronolith=2.3.5-debian5.0.build1013111101.14 psa-mimp=1.1.3-debian5.0.build1013110801.18 psa-mnemo=2.2.4-debian5.0.build1013111101.14 psa-passwd=3.1.3-debian5.0.build1013111101.14 psa-turba=2.3.5-debian5.0.build1013111101.14
    E: Broken packages
    ---X--- `apt-get` output ---------------------
    Reading package lists...
    Building dependency tree...
    Reading state information...
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    plesk-mail-pc-driver: Conflicts: psa-mail-driver
    psa-mail-pc-driver: Conflicts: psa-mail-driver

    ---------------------- `apt-get` output ---X---
    Fehlerdetails werden in die Protokolldatei geschrieben...

    -------------------------------------------------------------------------------------------------------------

    i can't submit the installation error log because ...
    " /opt/psa/admin/bin/send-error-report install
    /opt/psa/admin/bin/send-error-report: error while loading shared libraries: libboost_thread-gcc42-mt-1_34_1.so.1.34.1: cannot open shared object file: No such file or directory"
     
  2. minosj

    minosj Basic Pleskian

    17
     
    Joined:
    Oct 26, 2010
    Messages:
    34
    Likes Received:
    0
    Hi,

    Try the command " apt-get install psa-mail-qc-driver " and see what happens in the server.

    Thank you.
     
  3. thE_iNviNciblE

    thE_iNviNciblE Guest

    0
     
    hi,

    apt-get install psa-mail-qc-driver


    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    psa-qmail psa-qmail-rblsmtpd
    Die folgenden Pakete werden ENTFERNT:
    plesk-mail-pc-driver postfix postfix-pcre
    Die folgenden NEUEN Pakete werden installiert:
    psa-mail-qc-driver psa-qmail psa-qmail-rblsmtpd
    0 aktualisiert, 3 neu installiert, 3 zu entfernen und 107 nicht aktualisiert.
    Es müssen 1078kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 3277kB Plattenplatz freigegeben.

    it suggests to install three packets "psa-qmail psa-qmail-rblsmtpd"...

    isn't it dangerous to install a part *.deb of plesk server?
     
  4. SalvadorS

    SalvadorS Regular Pleskian

    29
    90%
    Joined:
    Nov 12, 2009
    Messages:
    282
    Likes Received:
    2
    Hello,

    Same problem here. If I try to install psa-mail-qc-driver:

    apt-get install psa-mail-qc-driver

    Debian want to delete:

    postfix postfix-pcre psa-mail-pc-driver

    And want to install

    psa-mail-qc-driver psa-qmail psa-qmail-rblsmtpd

    So it want to switch from postfix to qmail, and I don´t want this...

    Any solution?
     
  5. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    I think you should just remove psa-mail-pc-driver package (it should not be present in 10.4.4 anyway) and then proceed with upgrade via Autoinstaller.

    send-error-report error is quite weird, since libboost_thread-gcc42-mt-1_34_1.so.1.34.1 was used only on Debian 4 or less, if I'm not mistaken. You can try to use Autoinstaller from Plesk 11 (i.e. with version 3.12). It should be free of such errors. Of course, it will be able to install Plesk 10 as well. Just specify --all-versions, if you don't see Plesk 10.4.4 in the releases list.

    Also, you might consider upgrading to Plesk 11 altogether.
     
  6. SalvadorS

    SalvadorS Regular Pleskian

    29
    90%
    Joined:
    Nov 12, 2009
    Messages:
    282
    Likes Received:
    2
    The problem with the upgrade to Plesk 11 is that Plesk 11 is only compatible with Debian 6 and not with Debian 5.
     
Loading...