1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10.4.x makes having a compiled version of php NOT USABLE ! plesk 6,7,8,9 are ok

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by andyb-uk, May 29, 2012.

  1. andyb-uk

    andyb-uk New Pleskian

    20
     
    Joined:
    Aug 17, 2009
    Messages:
    15
    Likes Received:
    0
    Hi

    I have been using Plesk in a hosting environment for over 6 years now.

    One of the common things our clients ask for is a custom compiled version of PHP.

    In the past I have always just compiled from source to /usr/local/php_apache and /usr/local/php_cgi - usually i symlink /usr/bin/php5-cgi to /usr/local/php_cgi/bin/php-cgi - this has always been fine (for years...)

    With the changes in the latest version (10.4.x) the Plesk autoupdates randomly change the version of php randomly back to the original os version (thus breakiing everyone's sites !!!)

    - In Debian/Ubuntu I can't hold the package (in apt) or Plesk is not able to update - it actually managed to get debian depency hell (pretty rare)
    - The same occurs in Centos btw (with plesk 10.4.x)

    To try to combat this I am now atempting to make ubuntu 8.04 debian packages of php 5.3.10 (for example) - this would 'fix' the issue as the version number will be higher that the version in the OS so it will not automatically updated (as its a higer version number) - this is however a far far far more complex task than just compiling from source...

    For example I have an ubuntu8.04 server that requires the latest 5.3.x PHP - normally I would just compile from source, it would be a 30 mins job max - right now i'm on day 2 of trying to backport ubuntu 12.04 php5 packages to 8.04 - The thing is if they were runnig Plesk 9 I wouldn't need to bother creating packages (a simple source install works)

    Is there an actual sane method to have a compiled version of PHP, and ensure it won't randomly change and still update Plesk ??

    - Right now I am advising clients to stick with Plesk9 / use cpanel

    (I should note in Cpanel its really easy to have the latest stable PHP (without breakling your server.......))

    Any advice is welcomed... The standard OS version of php53 for centos is pretty old now (5.3.3) and we aqre getting requests to upgrade it constantly..
     
    Last edited: May 29, 2012
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Plesk doesn’t ship client’s PHP, it only downloads it from original OS vendor repo and it is quite likely it may be outdated there (especially for older OS). If your OS comes with latest version of PHP, then Plesk would run this latest PHP for clients.
     
  3. andyb-uk

    andyb-uk New Pleskian

    20
     
    Joined:
    Aug 17, 2009
    Messages:
    15
    Likes Received:
    0
    Hi

    Thats not the point at all......

    The point is that since the autoupdater features in Plesk 10.x if you have a custom compiled version of PHP it gets automatically replaced by the Plesk autoupdater (this has happened on multiple servers / different distros.... ALL were fine on Plesk 9 and below.)

    This didn't happen in older versions of Plesk.

    Are you saying that the autoupdater/microupdates do not replace the php binary beacuse 'something' that Plesk 10.4.x installs does...

    I know you won't 'support' a compiled version of PHP, I just want to have the ability to compile my own and NOT have to randomly replaced....

    Any help wouid be good - it is only Plesk (10.x) servers that I have ever seen that have this issue
     
    Last edited: May 29, 2012
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    For yum, add into /etc/yum.conf something like

    exclude=php*
     
  5. andyb-uk

    andyb-uk New Pleskian

    20
     
    Joined:
    Aug 17, 2009
    Messages:
    15
    Likes Received:
    0
    Hi

    I have tried the equivlent in debian/ubuntu


    i.e :-

    echo php5 hold | dpkg --set-selections

    That then causes a dependecy hell with Plesk updates....

    Is there a better way?

    Thank you for your quick responses.

    Sorry about the tone of my email its just Plesk 9.x used to be more 'accepting' of compiled software.
     
Loading...