• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PLESK 12.5: AH01071: Got error 'Primary script unknown\n'

ehrenwert

Basic Pleskian
Hello,

since a few days I'm getting more and more errors like this in my php error logs:

Code:
[Tue Nov 24 16:07:04.025470 2015] [proxy_fcgi:error] [pid 20003:tid 139677277275904] [client 95.90.226.xx:58930] AH01071: Got error 'Primary script unknown\n', referer: https://www.example.com/mypage/test
[Tue Nov 24 16:07:50.545155 2015] [proxy_fcgi:error] [pid 20003:tid 139677436737280] [client 212.202.164.xxx:59880] AH01071: Got error 'Primary script unknown\n', referer: https://www.example.com/mypage/test
[Tue Nov 24 16:07:50.731797 2015] [proxy_fcgi:error] [pid 20003:tid 139677285668608] [client 212.202.164.xxx:59886] AH01071: Got error 'Primary script unknown\n', referer: https://www.example.com/mypage/test
[Tue Nov 24 17:17:32.102749 2015] [proxy_fcgi:error] [pid 20003:tid 139677436737280] [client 77.23.246.xxx:54530] AH01071: Got error 'Primary script unknown\n', referer: https://www.example.com/mypage/test
[Tue Nov 24 17:36:35.584039 2015] [proxy_fcgi:error] [pid 20003:tid 139677260490496] [client 95.115.140.xx:44838] AH01071: Got error 'Primary script unknown\n', referer: https://www.example.com/mypage/test

Is this related to plesk fpm? Any ideas how to solve this?
 
This looks like already submitted bugreport PPP-16560
Developers are working on it. As possible workaround you can try to use fastcgi PHP handler instead of php-fpm
 
This looks like already submitted bugreport PPP-16560
Developers are working on it. As possible workaround you can try to use fastcgi PHP handler instead of php-fpm

Is there an ETA for a fix for this? Curious. :)
 
Hackers use wrong URLs often AND Fail2Ban Filter dont filter this hackings!
So we have test with many different filters and with fail2ban-regex we get good matched results but with running the filter they ignore the regex - without notice / without info!
So we need urgend a function fail2ban-filter or a resulution why this message in error_log equal not in the modsec audit logs!
 
Back
Top