1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk 7.5 Reloaded - psa-security missing Error

Discussion in 'Plesk for Linux - 8.x and Older' started by pelsam, Apr 25, 2005.

  1. pelsam

    pelsam Guest

    0
     
    I get the following error when attempting to install Plesk 7.5 Reloaded
    on a Fedora Core 2 system

    [root@xxxx base]# rpm -Uvh psa-7.5.2-fc2.build75050128.11.i586.rpm
    error: Failed dependencies:
    psa-api-cli >= 7.5.2 is needed by psa-7.5.2-fc2.build75050128.11
    psa-api-common >= 7.5.2 is needed by psa-7.5.2-fc2.build75050128.11

    [root@xxxx base]# rpm -Uvh psa-api-cli-7.5.2-fc2.build75050128.11.i586.rpm
    error: Failed dependencies:
    /usr/local/psa/admin/bin/php is needed by psa-api-cli-7.5.2-fc2.build75050128.11
    psa-api-common = 7.5.2 is needed by psa-api-cli-7.5.2-fc2.build75050128.11

    [root@xxxx base]# rpm -Uvh psa-api-common-7.5.2-fc2.build75050128.11.i586.rpm
    error: Failed dependencies:
    /usr/local/psa/admin/bin/php is needed by psa-api-common-7.5.2-fc2.build75050128.11
    psa-security = 7.5 is needed by psa-api-common-7.5.2-fc2.build75050128.11

    [root@xxxx base]#


    Can anyone help me figure out why I'm getting this error and how to
    resolve it? Neep help ASAP!

    Thanks
    sam75
     
  2. ehoff

    ehoff Guest

    0
     
    here also

    i'm getting this too..how did you fix yours?
     
  3. jamesyeeoc

    jamesyeeoc Guest

    0
     
    What version of Plesk is currently running on your server?
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    How are you installing Plesk, using the autoinstaller or doing it manually? Also, what OS?
     
  5. editor

    editor Guest

    0
     
    I think, this file is only for updating from 7.5 to 7.5.2, but he did not have 7.5 running onto this server.
     
  6. dm__@

    dm__@ Guest

    0
     
    You should install psa, psa-api-common and psa-api-cli simultaneously: psa requires psa-api-cli & psa-api-common, and provides psa-api-security needed by the psa-api-cli & psa-api-common.
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    He's doing an RPM install on FC2 according to his original post. But he still has not responded as to what version of Plesk he is starting from....

    In case he doesn't know how to install them all at same time:

    rpm -Uvh psa psa-api-common psa-api-cli

    You put all the package names on same line, separated by spaces.

    (don't know his level of experience, no offense meant)
     
  8. dm__@

    dm__@ Guest

    0
     
    Re: Re: Plesk 7.5 Reloaded - psa-security missing Error



    In the log there was no errors regarding the broken dependencies between the old versions of psa-api-* and new version of psa, so it seems to be a fresh install.
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Doh! Ok, I missed that.....thanks.
     
Loading...