1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Plesk 7.52 And FreeBSD

Discussion in 'Plesk for Linux - 8.x and Older' started by jprince, Feb 10, 2005.

  1. jprince

    jprince Guest

    0
     
    I thought I would try to move some of the known fixes to
    a common area for the FreeBSD users.
    I have attached a link to a file that contains the fixes.
    The file contains a single tarball containing the 4
    files listed below. The tarball is rooted to /usr/local.
    No script is provided to install the files, since I assume
    most should be able to perform this without a problem.
    It is important that you make sure the permissions are
    set as indicated. You might also want to backup the
    original files before you proceed.

    When the next Hotfix or Release comes out, we will update
    this post to reflect the changes.
    It is assumed that you have already applied the existing
    Hot Fix. If not, you will need to do so before you continue.
    Hotfix Release on Feb 4, 2005 FreeBSD 4.9
    Hotfix Release on Feb 4, 2005 FreeBSDBSD 5.3

    The following items have been addressed by SW-Soft, and
    are not included in the current HotFix dated Feb 4, 2005.
    And are for the FreeBSD 4.9 release. They have not been
    tested on FreeBSD 5.3.

    • Problem migrating accounts from another Plesk Server
      File: /usr/local/psa/admin/sbin/launchpad
      Permissions: plesk : plesk 0755
    • Spamassassin configure with wrong qmail base path
      File: /usr/local/psa/spamassassin/bin/spamd
      Permissions: root : wheel 0755
      FIle: /usr/local/psa/lib/perl5/site_perl/5.005/Mail/SpamAssassin/CmdManage.pm
      Permissions: root : wheel 0644
    • Problem accessing domains. Blank page displayed
      File: /usr/local/psa/admin/plib/class.DomainControlForm.php
      Permissions: root : psaadm 0550

    Download Updates

    Cheers
     
  2. jas8522

    jas8522 Basic Pleskian

    24
    23%
    Joined:
    Feb 3, 2005
    Messages:
    80
    Likes Received:
    0
    Location:
    Halifax, Nova Scotia Canada
    Thanks!

    This should really be stickied - this is a serious problem that is well addressed by this patch.

    And don't forget to run the update utility/apply the official patch mentioned there before doing this!

    If you're attempting to use this, make sure you follow the directions explicitly, otherwise it's not going to work!

    thanks jprince!
     
  3. carlosho17

    carlosho17 Guest

    0
     
    Hi there,

    I came across a new problem with 7.5.2 on FreeBSD 4.9

    My customers are complaining that they cannot use the backup function for their domains.

    In fact, when you click into Backup from control panel, following message shows up:

    ERROR

    DumpsList::init() failed: filemng failed: filemng: opendir failed: Permission denied

    0: /usr/local/psa/admin/htdocs/domains/backup/dumps_list.php:248 psaerror(string "DumpsList::init() failed: filemng failed: filemng: opendir failed: Permission denied")

    I tried with several domains, and all got the same error.

    CHeers,

    /Carlos
     
  4. audun1

    audun1 Guest

    0
     
    I have problem whit reciving Email's . And sending email as well.

    This doesen't fix it. HELP many people is angry:mad: on me.....

    Hope i't will be a fix.

    I have done all the things that have been post here before butt nothing works ..

    Sorry for my bad English...
     
  5. carlosho17

    carlosho17 Guest

    0
     
    A solution for the backup problem I posted earlier is (according to Plesk support or bugreport):

    chown psaadm:psaadm /usr/local/psa/var/dumps

    Domain directories are created under this directory with the right permissions now, I think they got the wrong permissions either during upgrade to 7.5.2 or during the time of 7.0.x

    -Carlos
     
  6. jprince

    jprince Guest

    0
     
    Hello audun1,
    First I am assuming you are using FreeBSD. Correct?
    After you have applied the hotfix, and the updates listed,
    did you perform the mchk -v ?

    Cheers.
     
  7. audun1

    audun1 Guest

    0
     
    Yes i'm FreeBSD user.

    And the HOTFIX is instaled.

    The commando is used, all the things I have found.

    Butt nothing works.
     
  8. jprince

    jprince Guest

    0
     
    Hello,
    Aside from running the hotfix, installing the file(s), and
    running mchk -v, I am not sure what might be causing your
    issue. I can only suggest that you contact SW-Soft Support
    and let them have a look.

    Sorry,
     
  9. audun1

    audun1 Guest

    0
     
    Maybe i must do that.
    Butt doesen't that require payin them for the support?

    I don't have paid support :D

    Maybe I shod start all over again and do it all ?

    what do you gays think:D
     
  10. egate

    egate Guest

    0
     
    Spamassassin wasn't working for me on 7.5.2 on FreeBSD 5.2. So I thought I'd give the above a go. I applied the FreeBSD 5.2 hotfix and followed the instructions. Spamassassin will not start now.

    GUI: Unable to make action: Unable to manage service by spamd: Unable to start server.

    Command line: Plesk: failed to start SpamAssassin

    Should I not have applied these updates to 5.2? Any ideas on getting spamassassin working?

    Many Thanks
    Jonny
     
  11. jprince

    jprince Guest

    0
     
    Hello,
    There is a seperate hotfix for FreeBSD 5.3.
    Try applying that instead of the one for 4.9.
    I modified the first post, to include it.

    The changes I posted, have only been tested on 4.9.
    While I assume they should work on 5.3, I have not
    tested them.

    Cheers.
     
  12. audun1

    audun1 Guest

    0
     
  13. audun1

    audun1 Guest

    0
     
    OK. I have installed the update (hotfix) and I tryd the pop3d command to restart it. This is the error:
    Code:
    
    
    PIDFILE=/var/run/pop3d.pid: Command not found.
    MAXDAEMONS=40: Command not found.
    MAXPERIP=4: Command not found.
    AUTHMODULES=: Command not found.
    AUTHMODULES_ORIG=: Command not found.
    DEBUG_LOGIN=0: Command not found.
    POP3AUTH=: Command not found.
    POP3AUTH_ORIG=LOGIN CRAM-MD5 CRAM-SHA1: Command not found.
    POP3AUTH_TLS=: Command not found.
    POP3AUTH_TLS_ORIG=LOGIN PLAIN: Command not found.
    PORT=110: Command not found.
    ADDRESS=0: Command not found.
    TCPDOPTS=-nodnslookup -noidentlookup: Command not found.
    POP3DSTART=NO: Command not found.
    MAILDIRPATH=Maildir: Command not found.
    AUTHMODULES=authpsa: Command not found.
    froysaa#
    What a ....... Can someone tell me whats going on. Or do someone have the file that works ? :D
     
  14. carlosho17

    carlosho17 Guest

    0
     
    Hi there,

    my apache server suddenly stops working under Plesk 7.5.2 for FreeBSD-4.9, build 75050204.18 ... it sits in some kind of a loop where it logs hundreds of this pair of lines in /usr/local/psa/apache/logs/error_log

    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument

    While in this zombie state, apache is unable to serve domains at all. I have to issue apachectl restart every hour per crontab to wake it up.

    -Carlos
     
  15. egate

    egate Guest

    0
     
    Hi

    It was the 5.3 hotfix that I applied. Quite unbelieveably I also overwrote the both copies of the orignal files on the server, is there a way to download just these files?

    One thing that did confuse me is:
    Permissions: plesk : plesk should this be root psaadm?

    Cheers,
    Jonny
     
  16. egate

    egate Guest

    0
     
    Just got spamassassin to start. I changed the first line in /usr/local/psa/spamassassin/bin/spamd to #!/usr/bin/perl -w !!

    Thing now is spam gets caught in a loop.
    ###edit#####
    not all the spam is bouncing as I've just had some mail tagged as spam come through. Not sure what's going on yet, I think it may just be that I was sending the spam from my address.

    After several hours it appears that my email address, which I am using for a test, is working correctly.

    So if you are using freeBSD 5.2 and want to use the spamassassin fix posted at the start of this thread change the first line of the new version of
    /usr/local/psa/spamassassin/bin/spamd
    to
    #!/usr/bin/perl -w

    This is not properly tested etc etc etc

    ##########

    A test non spam message gets through OK but if I send myself a test spam message I get it returned:

    Hi. This is the qmail-send program at my.lovely.plesk.box.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <jonny@xxxxxxxxxx.xx.xx>:
    This message is looping: it already has my Delivered-To line. (#5.4.6)

    Maillog looks like:

    Mar 18 11:25:04 chalk1 qmail: 1111145104.357418 new msg 8459628
    Mar 18 11:25:04 chalk1 qmail: 1111145104.359876 info msg 8459628: bytes 4080 from <jonny@xxxxxxxxxx.xx.xx> qp 24461 uid 2020
    Mar 18 11:25:04 chalk1 qmail: 1111145104.363983 starting delivery 661: msg 8459628 to local 1-jonny@xxxxxxxxxx.xx.xx
    Mar 18 11:25:04 chalk1 qmail: 1111145104.364367 status: local 1/10 remote 0/20
    Mar 18 11:25:04 chalk1 qmail: 1111145104.367742 delivery 661: failure: This_message_is_looping:_it_already_has_my_Delivered-To_line._(#5.4.6)/
    Mar 18 11:25:04 chalk1 qmail: 1111145104.369122 status: local 0/10 remote 0/20
    Mar 18 11:25:04 chalk1 qmail-queue: dwlib[24463]: scan: the message(drweb.tmp.SghnPU) sent by to jonny@xxxxxxxxxx.xx.xx is passed
    Mar 18 11:25:04 chalk1 qmail: 1111145104.493341 bounce msg 8459628 qp 24463
    Mar 18 11:25:04 chalk1 qmail: 1111145104.494039 end msg 8459628
    Mar 18 11:25:04 chalk1 qmail: 1111145104.497107 new msg 8459643
    Mar 18 11:25:04 chalk1 qmail: 1111145104.497498 info msg 8459643: bytes 4669 from <> qp 24464 uid 2522
    Mar 18 11:25:04 chalk1 qmail: 1111145104.500030 starting delivery 662: msg 8459643 to local 1-jonny@xxxxxxxxxx.xx.xx
    Mar 18 11:25:04 chalk1 qmail: 1111145104.500366 status: local 1/10 remote 0/20
    Mar 18 11:25:04 chalk1 spamd[24240]: got connection over /tmp/spamd_full.sock
    Mar 18 11:25:04 chalk1 spamd[24469]: Using default config for jonny@xxxxxxxxxx.xx.xx: /usr/local/psa/qmail/mailnames/xxxxxxxxxx.co.uk/jonny/user_prefs
    Mar 18 11:25:04 chalk1 spamd[24469]: processing message (unknown) for jonny@xxxxxxxxxx.xx.xx:110.
    Mar 18 11:25:09 chalk1 spamd[24469]: clean message (1.4/7.0) for jonny@xxxxxxxxxx.xx.xx:110 in 5.2 seconds, 4669 bytes.
    Mar 18 11:25:09 chalk1 qmail: 1111145109.728550 delivery 662: success: did_1+0+2/did_0+0+1/
    Mar 18 11:25:09 chalk1 qmail: 1111145109.729380 status: local 0/10 remote 0/20
    Mar 18 11:25:09 chalk1 qmail: 1111145109.729678 end msg 8459643

    Many thanks for any help

    Jonny
     
  17. audun1

    audun1 Guest

    0
     
    Hi again. I can send mail now butt i cant receive and the receiver cant receive my mail and i get this mail back:

    Code:
     Hi. This is the qmail-send program at froysaa.net.
    I'm afraid I wasn't able to deliver your message to the following addresses. This is a permanent error; I've given up. Sorry it didn't work out.
    
    <audun@pegma.no>:
    This address no longer accepts mail.
    
    --- Below this line is a copy of the message.
    
    Return-Path: <audun@wainsupport.com>
    Received: (qmail 2217 invoked from network); 17 Mar 2005 19:48:27 -0000
    Received: from 217-3-132.adsl.tele2.no (HELO TOSHIBA) (gfxvhcnjlz@193.217.3.132)
      by 206-225-86-196.dedicated.abac.net with SMTP; 17 Mar 2005 19:48:26 -0000
    From: =?iso-8859-1?Q?Audun_Fr=F8ysaa?= <audun@wainsupport.com>
    To: =?iso-8859-1?Q?'Audun_Fr=F8ysaa'?= <audun@pegma.no>
    Subject: d
    Date: Thu, 17 Mar 2005 20:47:52 +0100
    Message-ID: <001e01c52b2a$380acd60$0302a8c0@TOSHIBA>
    MIME-Version: 1.0
    Content-Type: multipart/mixed;
    	boundary="----=_NextPart_000_001F_01C52B32.99CF3560"
    X-Priority: 3 (Normal)
    X-MSMail-Priority: Normal
    X-Mailer: Microsoft Outlook, Build 10.0.2627
    Importance: Normal
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
    X-MS-TNEF-Correlator: 000000006604A685CD88E8448A48F60215774F8964E32000
    
    This is a multi-part message in MIME format.
    
    ------=_NextPart_000_001F_01C52B32.99CF3560
    Content-Type: text/plain;
    	charset="iso-8859-1"
    Content-Transfer-Encoding: 7bit
    
    dffkfkfkf
    
    ------=_NextPart_000_001F_01C52B32.99CF3560
    Content-Type: application/ms-tnef;
    	name="winmail.dat"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    	filename="winmail.dat"
    
    eJ8+IjkTAQaQCAAEAAAAAAABAAEAAQeQBgAIAAAA5AQAAAAAAADoAAEIgAcAGAAAAElQTS5N
    eJ8+aWNy
    b3NvZnQgTWFpbC5Ob3RlADEIAQ2ABAACAAAAAgACAAEGgAMADgAAANUHAwARABQALwAAAAQANwEB
    A5AGADgLAAAqAAAACwACAAEAAAALACMAAAAAAAMAJgAAAAAACwApAAA end so on
    As I sad earlyer maybe a update of just the courier server is a fix http://www.courier-mta.org/?download.php~imap

    Some reaply on this?:D

    EDIT::: The proftp server is also wery strange after the latest hotfix. I cant upload a file on 400kb whitout the server return a message
    Code:
     Connection closed
    Some thing IS verry wrong hehe :D
     
  18. audun1

    audun1 Guest

    0
     
    I must just say that I can receive mail whiteout a problem. All thing is working great. Except sending as show on the earlier post.
    I have take a picture from my screen in Plesk and there you can se that the red X is showing on Courier-imap. Butt the error I gets when I send mail is from Qmail.
    Is there something I have missed?
    Picture HERE

    Thanks in advanced
     
  19. audun1

    audun1 Guest

    0
     
    EDIT: Courier-imap is running butt i stil get the error from qmail?

    Sorry for my bad english
     
  20. jshanley

    jshanley Guest

    0
     
    The IMAP/POP3 having a red X is a bug on FreeBSD 5.x (not sure if it's a bug on 4.x).
    They logged into my server and changed a script that fixed it for a day, but it re-broke itself and I have the red X again for IMAP.

    It has something to do with Plesk checking to see if the wrong program is running for IMAP (courierlogger or something like that).

    I'll just wait until they release another patch I guess.
     
Loading...