1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 8.1 & PHP5 on Debian 3.1 ?!????

Discussion in 'Plesk for Linux - 8.x and Older' started by stamos, Feb 21, 2007.

  1. stamos

    stamos New Pleskian

    22
    23%
    Joined:
    Feb 19, 2007
    Messages:
    5
    Likes Received:
    0
    Hello,

    I have a fresh install of Plesk 8.1 on my debian 3.1 sarge system and I want to upgrade PHP vrom v. 4 to 5 but everytime I run the upgrade the system wants to remove several plesk packages in order that plesk wont work anymore.

    in my shell php5 seems to be installed with the autoinstaller from swsoft, at least it stats me PHP 5.14 but on Apache2 still php4 runs.

    What should I do?! :confused:
     
  2. XtremeCamera

    XtremeCamera Guest

    0
     
    I'm having the same problem... reformatted by drive, installed CentOS 4.4 and successfully installed Plesk 8.1.1 with the express purpose of wanting to get PHP 5 up and running on my server...

    Now I can't log into Plesk at all at the 8443 port.

    Can anyone help?
     
  3. gorilych

    gorilych Guest

    0
     
    This is known problem for deb OS like debian&ubuntu, it seems to be solved for psa 8.1.1 on debian
     
  4. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    if you don't use sitebulider uninstall it and then intsall psa-php5-configurator after this you can install php5 and remove php4 and php 5.1.4 which is used by sitebuilder
     
  5. skrieg2

    skrieg2 Guest

    0
     
    Hi,

    I tried all possible to install php5 from the official packages but I never did.

    I'm using dexter's repos.

    # PHP5.1 pour Debian sarge
    deb http://people.debian.org/~dexter php5.1 sarge
    deb-src http://people.debian.org/~dexter php5.1 sarge

    then
    apt-get update
    apt-get install php-5.1 and all the other packages you need
    a2dismod php4
    /etc/init.d/apache2 restart
     
  6. tnats@

    tnats@ Guest

    0
     
    I've got a new customer that wants php5.

    If I upgrade, will this force all current php scripts to use the php5 version? If so, I'm afraid all my other customer's scripts might have problems.

    Is everyone upgrading to php5? If so, how did it affect all your other customers?

    Thanks,
    Tom
     
  7. skrieg2

    skrieg2 Guest

    0
     
    Hi,

    You can use php4 installed as an apache module and php5 installed as cgi (or vice-versa). But you need to recompile and reconfigure. It requires some Linux skills and time.

    The biggest difference between php4 and php5 is the register_globals value set to Off in php5. We had to let it On because a lot of websites (we made) use register_globals (which is old-insecure-amateur coding style).

    If you plan to upgrade I recommend you to annouce to your customers early enough.

    You can easily set a local register_global value in the htaccess file of every site who needs it.

    Also be sure that the mysql API client version of php is compatible with the Mysql server.

    I advise you to install and upgrade all your stuff on a test server before doing this "live and direct" on the production server.

    Anyway, I'm using dexter's repos. Installed easily and no big trouble.

    Here's my complete howto (some of it is on the previous post).

    This howto worked with Debian 3.1 Sarge on my servers.

    Of course. I'm not responsible of your actions, if your server crashed, if your customers want to sue you or if you've been fired. Please be aware of what you are typing. Fear yourself when you are logged as root.


    1) Add This to your sources.list
    Code:
    # PHP5.1 pour Debian sarge
    deb [url]http://people.debian.org/~dexter[/url] php5.1 sarge
    deb-src [url]http://people.debian.org/~dexter[/url] php5.1 sarge
    
    # pear-package for Debian sarge
    deb [url]http://people.debian.org/~dexter[/url] pear-package sarge
    deb-src [url]http://people.debian.org/~dexter[/url] pear-package sarge
    2) Install php5 and pear
    Code:
    apt-get install libapache2-mod-php5.1 php5.1-curl php5.1-exif php5.1-ftp php5.1-gd \
    php5.1-gettext php5.1-mysql php5.1-sqlite php5.1-session php5.1-imap
    apt-get install pear-package
    Ad this stage: php4 and php5 are installed on your server. You can disable/enable both of them when you want:

    3) Enable php5
    Code:
    a2dismod php4
    a2enmod php5.1
    /etc/init.d/apache2 force-reload
    4) If things messed up, enable php4
    Code:
    a2dismod php5.1
    a2enmod php4
    /etc/init.d/apache2 force-reload
    good luck and have fun :p
     
  8. tnats@

    tnats@ Guest

    0
     
    Got it skrieg2!

    Thanks for the help.

    Now....how do I upgrade to mysql 5.... :)
     
  9. tfox

    tfox Guest

    0
     
    Sorry to drag up an old thread, but I seem to be running into the issue described in this thread.

    First off, I installed Debian Etch, and that worked fine. Then I performed an auto install of Plesk 8.2. At that point, the client wanted PHP5 installed. I followed normal procedures to install that, but it broke Plesk by uninstalling 4 packages that were needed. Reinstalling Plesk fixes that issue, but does not resolve the problem with not being able to parse PHP files (when you click on them, you get the option to download), and the components screen of Plesk lists PHP4, where as a 'php -v' from the command line shows PHP5.

    I've tried downloading the Debian PHP module file and adding it through the module feature of Plesk, but Plesk says it's an unsupported file.

    Does anyone have any suggestions or help?
     
  10. tnats@

    tnats@ Guest

    0
     
    Do you have the php - apache module?

    ie. libapache2-mod-php5? (or php4)


    dpkg -l | grep libapache
     
  11. tfox

    tfox Guest

    0
     
    I just verified it was there. Thanks for the suggestion.
     
  12. tnats@

    tnats@ Guest

    0
     
    If you email me, I can send you my apache config files or whatever you need. I have 2 Plesk debian boxes.
     
  13. tfox

    tfox Guest

    0
     
    Thanks for all of your help. I think I have it resolved. For some reason I reinstalled PHP5 & Plesk for the 4th or 5th time and after forcing a restart of apache, it started to work. I’m waiting on verification that it is working to specs. If not, I may post back with some more questions if it does not work. Thanks for all of your help.
     
Loading...