1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 9.3 + Debian Lenny + Overused Disk Space Statistic not updating

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Angels, Feb 10, 2010.

  1. Angels

    Angels Guest

    0
     
    I used Plesk 9.3 with Debian etch and backuped the system with Plesk. After a complete new installation of Debian *lenny* (64bit) with Plesk 9.3 and restoring the backup i saw that a user had overused her disk space.

    She deleted the files (which is 10 days) ago, but the disc usage statistics wont update.

    Thats what i tried this far:

    - piped logs seem to work
    - /opt/psa/admin/sbin/statistics --calculate-one --domain-name=DOMAIN.tld ran without a visible error
    - /opt/psa/admin/sbin/statistics ran without a visible error
    - /opt/psa/bin/sw-engine-pleskrun /opt/psa/admin/plib/DailyMaintainance/script.php ran without a visible error
    - I switched from "file size" to "amount of disk space used" back and forward (with letting the statistic recalculate every time)

    The AWStats statistics are recreated, but not the disc usage statistics. Those still show the wrong size.

    Any Hints what else i can try / do?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Very difficult to say what is wrong there if you haven't any errors. Maybe size is not wrong?
     
  3. Angels

    Angels Guest

    0
     
    I found out what the problem was - ( YEAH for me :) ) - Maybe this is a bug?

    For some reason the complete backup i did as Admin was counted into the disk usage statistic of the customer. I think this is because a complete backup contains parts of each customer webspace.

    After i moved the files from /var/lib/psa/dumps/ to a secure location (because i was unsure if it is a good idea to delete everything from this dir) and did a rerun of /usr/local/psa/admin/sbin/statistics --calculate-one --domain-name=DOMAIN.TLD the statistics were correct again.
     
  4. CiprianP

    CiprianP Guest

    0
     
    It was the same problem for me too, how can this be possible? I have only problems with this plesk s*it piece of sw. I moved my backups just to test your fix and indeed it's the same case for me too. Now stats show ok, but after tonight's backups they will be compromised again...

    What's the solution? Not backup anymore? Thank you plesk for wasting my time and my company's time and money.

    I will certainly find an alternative ASAP and find ways to remove all my plesk installations.

    Cheers!
     
  5. Superkikim

    Superkikim Regular Pleskian

    25
    57%
    Joined:
    Mar 10, 2008
    Messages:
    135
    Likes Received:
    0
    no backup in statistics

    sh*t piece of software ? or ignorant users ?

    Please try to be polite. If you don't like the software, just use another one. I'm tired of people criticizing the software, but still using it !

    Go to Settings => Settings of server statistics => System Preferences

    Under Include in the disk space usage calculation, uncheck domain backup files
     
  6. CiprianP

    CiprianP Guest

    0
     
    Found that, thanks for taking time to reply.

    Maybe it's just me but I believe it's not normal to leave that checkbox on by default. People like improvements but they don't like other people force-feeding the improvements to them like in this case.

    I like things to go smooth and I upgrade for the stability and security, not for features necessarily. If I want to see what's new I can read the "What's New" link.
     
  7. EhsanV

    EhsanV Guest

    0
     
    I have same problem, after i deleted some files, overused disk space statistic not updated yet. note that Overuse is allowed and i copied some large files to the httpdocs folder.
     
  8. ManouchehrN

    ManouchehrN Guest

    0
     
    Very thanks from Superkikim

    Very very thanks Superkikim. I created this account only to gratefull from you.
    but also i agree with CiprianP for this idea "...I believe it's not normal to leave that checkbox on by default."
    again very thanks for your great help.
     
Loading...