• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Plesk Admin - 500 Internal Server

M

mpeters13

Guest
Server: CentOS 6 with Parallels Plesk Panel 10 (64-bit)

Hi. I'm in the process of moving my site from DreamHost to 1and1. 1and1 uses Plesk as a frontend for their dedicated server customers. I have little experience with Plesk, however.

I was troubleshooting some permissions on a site and accidentally ended up chown 755 to every file on my root partition.

Per several posts and blogs on the Internet, I have performed the following commands:

rpm --setugids -a
rpm --setperms -a

These commands, however, do not appear to repair the permissions on the /usr/local/psa folder.

After repairing permissions, the panel still wouldn't load.

I used the information here: http://kb.parallels.com/en/1528 to confirm the permissions on verified the permissions on /usr/local/psa/admin/sbin/*wrapper for ownership by root:psaadm (chmod 4110)

After a full day of googling, I'm left with this error (tailf -f /var/log/sw-cp-server/error_log):

2012-04-24 13:01:12: (mod_fastcgi.c.893) bind failed for: unix:/usr/local/psa/tmp/sw-engine.sock-0 Address already in use
2012-04-24 13:01:12: (mod_fastcgi.c.1105) [ERROR]: spawning fcgi failed.
2012-04-24 13:01:12: (connections.c.1737) SSL (error): 5 -1 0 Success


Can someone provide the default permissions and ownership rights for the /usr/local/psa directory and its children? If someone could also provide a better explanation of the error message above, I would appreciate it. I can only assume it's a wrapping issue, but I can't discern much more than that. If you require more information, please let me know.

Thank you.
 
Back
Top