1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Backup Command Line

Discussion in 'Plesk for Linux - 8.x and Older' started by datzis, Aug 16, 2008.

  1. datzis

    datzis Guest

    0
     
    Hey

    I trie to backup the hole Plesk and I want to exlclude domains!

    Is this right command right? because it is not working!

    /opt/psa/bin/pleskbackup -v all exclude=*******.de /home/pleskbackup_test

    Thanks for help!
     
  2. datzis

    datzis Guest

    0
     
    Nobody knows anything?
     
  3. padani

    padani Guest

    0
     
    Hello ,

    This is a forum here people voluntarly help others .So it would be inappropriate to say others ddin know the answers.

    Any way try with

    --exclude Specifies the items (domain names or clients' login names separated with white spaces) that should not be backed up.
     
  4. datzis

    datzis Guest

    0
     
    I did it now like this:

    /opt/psa/bin/pleskbackup -v all --exclude=test.de /home/pleskbackup_test

    Than he says: unknown option: exclude
     
  5. padani

    padani Guest

    0
     
    it should work .I have did this 1001 times .
    1)check the backup module rpm is installed
    2)or check the pleskbackup binary is there in the bin directory
     
  6. datzis

    datzis Guest

    0
     
    Thanks for you help so far!

    I checked the 2 Points and there are fine!

    I am doing Backups with pleskbackup now for a while!
    normaliy I do it this way:
    /opt/psa/bin/pleskbackup all ftp://???????:??????????@??????????.de/pleskbackup_test
    And its working just fine!! Is backups the hole plesk und I restored once with pleskrestore and it worked!

    But now I have one Domain I dont wont to backup up! Just one! And this time I used this line:
    /opt/psa/bin/pleskbackup -v all --exclude=???????.de /home/pleskbackup_test

    The error is: "Unknown option: exclude"
    Why is the command "exclude" for him a error?
    in "/opt/psa/bin/pleskbackup --help" he is saying me I can do this!
    Is my commandline wrong?
    /opt/psa/bin/pleskbackup -v all --exclude=???????.de /home/pleskbackup_test
     
  7. datzis

    datzis Guest

    0
     
    Is still not working?

    /opt/psa/bin/pleskbackup -v all --exclude=???????.de /home/pleskbackup_test

    Whats wrong?
     
  8. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    [root@heracles ~]# /usr/local/psa/bin/pleskbackup --help
    Usage: pleskbackup [<global-options>] <command> [<FTP options>] [<local-options>] <arguments>
    <output-file>

    Global options:
    -v|--verbose
    Show more information about backup process. Multiple -v
    options increase verbosity.

    -c|--configuration
    Backup only configuration of objects, not the content.

    -s|--split[=<size>]
    Split the generated backups to the parts. Parts are numbered
    by appending .NNN suffixes, starting with .001.

    Size may be specified in kilobytes (<nn>K), megabytes (<nn>M)
    and gigabytes (<nn>G).

    '-s' option without argument selects default split size:
    2 gigabytes.

    -z|--no-gzip Do not compress backup file

    Commands:
    all Backs up whole Plesk.

    clients Backs up selected clients. Clients are read from command line,
    space-separated. If no clients provided, backs up all clients
    on the host.

    domains Backs up selected domains. Domains are read from command line,
    space-separated. If no domains provided, backs up all domains
    on the host.

    Options --exclude and --exclude-file may be specified for
    excluding some clients/domains.

    help Shows this help page

    FTP options:
    --ftp-login=<ftp_login>
    Specify the FTP login
    --ftp-password=<ftp_password>
    Specify the FTP password (used with '--ftp-login')

    Local options:
    -f|--from-file=<file>
    Read list of domains/clients from file, not from command line.
    File should contain list of domains/clients one per line.

    --exclude=<obj1>,<obj2>,...
    Excludes listed domains/clients from backup list.

    --exclude-file=<file>
    Excludes domains/clients listed in file from backup list.
    File should contain list of domains/clients one per line.

    --skip-logs Do not save log files in the backup file

    Output file:
    /fullpath/filename - regular file,

    - - use stdout for output,

    ftp://[<login>[:<password>]@]<server>/<filepath> - storing the backup to ftp server.
    FTP_PASSWORD environment variable can be used for setting password.
    FTP option '--ftp-login' can be used for setting login.
    FTP option '--ftp-password' (with '--ftp-login') can be used for setting password.

    [root@heracles ~]#


    based on that, you should check the online documentation to see if there is something that you are missing.
     
  9. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    I just tried myself to see

    [root@heracles server]# /usr/local/psa/bin/pleskbackup -v all exclude=domaintoexclude.com backup_aug_23_2008
    ------------------------------------------------------------------------
    Backup started (X client(s), YYY domain(s))
    Start date: Sat Aug 23 23:06:23 2008
    ------------------------------------------------------------------------
    Phase 1/2: collecting information
    ..............................
    ..............................
    ..............................
    Phase 2/2: packing data

    I'll update when finished, will take some time to finish.
     
  10. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    so check your command, i just went again through the whole post, and i noticed you use "--exclude" when should be "exclude" without the "--"

    Give a try without the -- and should work.

    my backup is still running tho, so I cant post my backup output just yet.
     
  11. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    ok for me worked ;)

    try it without the --
    [root@heracles server]# /usr/local/psa/bin/pleskbackup -v all exclude=domaintoexclude.com backup_aug_23_2008
    ------------------------------------------------------------------------
    Backup started (X client(s), YYY domain(s))
    Start date: Sat Aug 23 23:06:23 2008
    ------------------------------------------------------------------------
    Phase 1/2: collecting information
    ..............................
    ..............................
    ..............................
    Phase 2/2: packing data
    ------------------------------------------------------------------------
    Backup finished.
    Finish date: Sun Aug 24 03:57:04 2008
    ------------------------------------------------------------------------
    [root@heracles server]#
     
  12. pippin

    pippin Guest

    0
     
    whats the command line for restore the domains?
     
  13. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
  14. OZyryanov

    OZyryanov Guest

    0
     
    Hello!
    This problem (with --exclude option) will be fixed soon. The hotfix is being prepared.
    Tnanks.
     
  15. datzis

    datzis Guest

    0
     
    I did it now exactly this way!

    /usr/local/psa/bin/pleskbackup -v all exclude=mydomain.de backup_aug_23_2008

    But he still includes the domain "mydomain.de" in the backup!!

    And I did

    /usr/local/psa/bin/pleskbackup -v all backup_aug_23_2008_2

    And it is the same size like the backup before.....
     
  16. OZyryanov

    OZyryanov Guest

    0
     
    Please read this!!!

    This problem (with --exclude option) will be fixed soon. The hotfix is being prepared.

    Tnanks.
     
  17. datzis

    datzis Guest

    0
     
    ok! I will wait!

    Just wondered that it worked with JLChafardet

     Hoppe the hotfix is coming sooooooon
     
  18. datzis

    datzis Guest

    0
     
    Hey all its me again! Greetings from Germany :)

    I installed the hotfix and the command --exclude is working now, but I have still the same problem!

    If I make a normal backup with this commandline:

    /opt/psa/bin/pleskbackup -v all /home/pleskbackup_test

    the backup is ~4.3GB large! So far so good

    Than I use this commandline to exlude one Domain with the size of ~1.4GB

    /opt/psa/bin/pleskbackup -v all --exclude=mydomain.com /home/pleskbackup_test

    And the result is, that this backup file is the size of ~4.3GB!
    Its the same size like the bakcup without the exclude command!

    Pleskbackup is not showing any error or so he is just not excluding anything....

    Is anybody seeing a error in my tought? Can it be that by pleskbackup file on the root is coruppted?
     
  19. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    indeed for me it worked ;) i removed from the backup a domain that is about 9 gb, the difference is file size, is noticeable.
     
  20. datzis

    datzis Guest

    0
     
    But is not working for me! Perhaps someone can send me the pleskbackup file via email than I can replace my file on the root! I dont know why this is not working!
    Email: info@onlineforyou.de

    Thanks
     
Loading...