1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Billing upgrade 5.6 standalone to 6 bundled fails.

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by ZopfWare, Dec 23, 2008.

  1. ZopfWare

    ZopfWare Regular Pleskian

    25
    57%
    Joined:
    May 30, 2004
    Messages:
    215
    Likes Received:
    0
    After hours of fiddling around I think I have Plesk 9 w/Plesk Billing 6 installed. I managed to get my data transferred (I think It's all there -- lots of backups!) however, none of the website widgets work now! I am very disappointed, as are my customers. It worked alot better when it was a standalone, and I'm busy trying now to get my old 5.6 standalone working again. Does anyone know why the widgets don't work?

    I have noticed that some of the php calls would appear to violate open_basedir restrictions, but I don't get any error to that effect.

    The entire billing system is accessed through port 8443 like the CP.

    I think this is where the problem is though....

    The website widget creates the following code on the page:

    ink rel="stylesheet" type="text/css" href="https://zopfware.com/plesk-billing/lib-themes/xpreloaded/lib-modernbill/css/shoppingstyle.css" />


    <script language="JavaScript" type="text/javascript" charset="utf-8" src="https://zopfware.com/plesk-billing/lib-action/include/js/scriptaculous/lib/prototype.js"></script>
    <script language="JavaScript" type="text/javascript" charset="utf-8" src="https://zopfware.com/plesk-billing/lib-action/include/js/scriptaculous/src/scriptaculous.js"></script>
    <script language="JavaScript" type="text/javascript" charset="utf-8" src="https://zopfware.com/plesk-billing/lib-action/include/js/scriptaculous/src/unittest.js"></script>
    <script language="JavaScript" type="text/javascript" src="https://zopfware.com/plesk-billing/lib-action/include/js/toggle.js" charset="utf-8"></script>
    <script language="JavaScript" type="text/javascript" src="https://zopfware.com/plesk-billing/lib-action/include/js/main.js" charset="utf-8"></script>
    <script language="JavaScript" type="text/javascript" src="https://zopfware.com/plesk-billing/lib-action/include/js/../ajax/core/ajax.inc.js" charset="utf-8"></script>

    <script language="JavaScript" type="text/javascript" charset="utf-8">
    // <![CDATA[
    var currentdomainform = "";

    var lastsiid = '';
    var istransfer = 0;
    var locale = "";
    var slURL2 = 'https://zopfware.com:8443/plesk-billing/app-modernbill-order/remotewhois.php?sid=091520894574a262fca3f4470fb34c824990f6e0&checkwhois=1&orderFormID=1';

    and it appears to me that for some reason it is creating the javascript url's WITHOUT the :8443 that is needed.

    This would be fine if this were a standalone instead of bundled version of plesk billing.

    I guess this is why the widget appears on the page but none of the buttons work.


    Anyone have any suggestions?
     
Loading...