1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PLESK client does not let me add a domain

Discussion in 'Plesk for Linux - 8.x and Older' started by crops, Jul 18, 2005.

  1. crops

    crops Guest

    0
     
    Hello,

    why do i get an error that there are no IPs in the clients IP Pool and that i should go to the IP pool functions and assign there an ip while there are no IPs in the IP pool, while i'm trying to add a domain for a PLESK client?

    Note: i did setup the Plesk client before the domain name was available, but now it is and has the same nameservers as my VPS, but no luck. The domain is registered in my HSP Complete and is binded with the same account that the PLESK client is...

    Anybody??
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If you don't assign any IPs into the Client pool, then you will not be able to assign any IPs to any domain under that Client.

    Go to the Client screen, go to IP Pool, click on Add new IP Address and assign at least one IP to the client. Then you should be able to create a domain(s) under that client and pick an IP address from the assigned pool.
     
  3. crops

    crops Guest

    0
     
    Hi,

    as i mentioned above i did already go to the client screen into the IP pool and there were no IPs to assign at all..thus cannot proceed with the procedure..Why are there no IPs in the Client's pool, while i have 29 more accounts that i can create? or is it maybe you are refering to a different client screen? i' m refering to the Control panel of the client(which i believe thats the one you are refering to)
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The pool is initially empty. Do you mean that 'after' you clicked Add New IP button, it did not show you any IPs to pick?

    And you do have at least 1 'shared' IP address defined in Server IP Addresses, right?
     
  5. crops

    crops Guest

    0
     
    Yes after i clicked the add new domain the IP pool is empty.

    as far as it concerns the Server IP Addresses, I went to the control panel of my VPS under server info and under IP addresses there is one IP address defined as static.

    If i go to the HSP Reseller Control center and go under IP Manager i cant see any IP Pools there or any IPs or anything else... this was from the begining like that when my VPS was setup by my hosting provider.

    the first account that i created and assigned an already registered domain(as im trying to do in this situation here as well) was done with no problems...assigned physical hosting to that..If i go to the first client and click on his domain his IP address has next to it the word " Exclusive "...

    does this mean that my VPS IP is not a shared IP?
    Might be that my VPS wasnt setup correctly?
    Where is an indication that my VPS IP is a shared IP?
     
  6. crops

    crops Guest

    0
     



    There is not ADD NEW IP button anywhere inside the IP Pool, unless i'm missing something here....
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If an IP is marked as 'exclusive', and if that IP is already used, then you would have to have additional IPs available.

    If the existing 'exclusive' IP is not needed for SSL Cert usage, then you could change it from Exclusive to Shared. You would do this in Server IP Addresses.

    If the domain which is using this exclusive IP *is* using an SSL cert, then you would have to have additional IPs to use for additional domains. A single 'shared' IP can be used for many domains (no SSL certs).

    Hope this clears it up.

    From your post it sounds like you have only a single IP on this server, is this right?

    That IP is marked as 'exclusive', and so is not a 'shared' IP.
     
  8. crops

    crops Guest

    0
     
    Hi again, yes indeed you did clear up things for me..

    It seems that i have only one IP asssigned to my VPS and so i need to talk to the hosting provider for that. My sites dont need SSL cert and i did checked out the SSL support in the first one...

    You mentioned that i can change the IP address fro exlusive to shared from IP addresses, but there is no option anywhere, neither from the Control panel of my VPS, neither from the HSP Complete control panel, so i guess this means that i cant change the IP from Exclusive to Shared...or can i change that by deleting the first domain that i created and redo the procedure again? (i dont remember seeing anywhere in the first domain setup that i did anything mentioning for a shared IP)...
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The option to change would be in Server - IP Addresses, but I believe Plesk will not allow you to change it if there is an existing domain using it.

    Option 1: delete domain, change IP to shared, re-create domain.

    Option 2: wait until you have more IP's, move the domain to a new shared IP, then change the exclusive IP to shared.
     
Loading...