1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

plesk config is messing up my qmail - need help deperately

Discussion in 'Plesk for Linux - 8.x and Older' started by jaymer, Jun 28, 2005.

  1. jaymer

    jaymer Guest

    0
     
    hi
    i had a new Fedora Core 2 dedicated server that i put plesk on at goDaddy. All worked but I was getting tons of spam - on my previous box all this was handled via cpanel/exim/spamassassin so the qty of spam didn't bother me. I had the hardest time getting QmailRocks to work - got stuck on the qmail-scanner step. I really needed spamassassin and i actually bought it from Plesk, but it wouldn't work so i dumped/uninstalled all the qmail/qmailrocks stuff i could find and started over.

    i trashed all that and reloaded qmail per LWQ.

    if i send myself an email from my yahoo account, then it goes to my local Maildir file in a directory i setup under Plesk... when i created myself as a webmail user long ago.
    so something is still running from the plesk side, and i think thats why i can't get vpopmail to work. after a server reboot, i have to stop courier/imap and attempt to stop qmail (which is broke in my version and wont stop)

    qmailctl reports that its only up 0 or 1 seconds - hey, i went through this long enough on the QMailRocks path to see the log and know that the problem is that vpopmail can't start... again, because the original "pop" system (whatever is was that Plesk injected) is still running. But i don't know how to stop it.

    At least I can get email by going to my server and do a "mail -f Maildir", but nothing ever shows up in any of the directories in the /home/vpopmail/domains/example.com/username/Maildir
    style that were created by QmailAdmin.

    here's my LOG processes:
    qmaill 17247 0.0 0.0 1776 328 ? S Jun22 0:00 /usr/local/bin/multilog t /var/log/qmail/smtpd
    qmaill 17251 0.0 0.0 2300 268 ? S Jun22 0:00 /usr/local/bin/multilog t /var/log/qmail/pop3d
    qmaill 19181 0.0 0.0 2020 328 ? S Jun22 0:01 /usr/local/bin/multilog t /var/log/qmail/send

    here's the supervise processes:
    root 2191 0.0 0.0 1984 272 ? S Jun17 0:00 supervise qmail-smtpd
    root 2192 0.0 0.0 1872 272 ? S Jun17 0:00 supervise log
    root 2194 0.0 0.0 2192 272 ? S Jun17 0:00 supervise log
    root 2195 0.0 0.0 2228 272 ? S Jun17 0:13 supervise qmail-pop3d
    root 2196 0.0 0.0 2572 272 ? S Jun17 0:00 supervise log
    root 6410 0.0 0.0 2728 272 ? S Jun17 0:00 supervise qmail-send

    qmail processes:
    qmails 17378 0.0 0.0 2388 364 ? S Jun22 0:02 qmail-send
    root 17380 0.0 0.0 2644 308 ? S Jun22 0:00 qmail-lspawn ./Maildir
    qmailr 17381 0.0 0.0 2072 316 ? S Jun22 0:00 qmail-rspawn
    qmailq 17382 0.0 0.0 2624 300 ? S Jun22 0:00 qmail-clean

    and these two tcpserver processes:
    root 13600 0.0 0.0 2004 476 ? S Jun17 0:00 /usr/local/bin/tcpserver -H -R 0 pop3 /var/qmail/bin/qmail-popup mail.jaymer.com /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir
    qmaild 17245 0.0 0.0 2660 484 ? S Jun22 0:00 /usr/local/bin/tcpserver -v -R -l mail.jaymer.com -x /etc/tcp.smtp.cdb -c 20 -u 2020 -g 2020 0 smtp /var/qmail/bin/qmail-smtpd


    and qmailctl reports:
    /service/qmail-send: up (pid 17378) 17117 seconds
    /service/qmail-send/log: up (pid 19181) 116268 seconds
    /service/qmail-smtpd: up (pid 17245) 117164 seconds

    /service/qmail-smtpd/log: up (pid 17247) 117164 seconds
    /service/qmail-pop3d: up (pid 29087) 0 seconds
    /service/qmail-pop3d/log: up (pid 17251) 117164 seconds
    messages in queue: 0
    messages in queue but not yet preprocessed: 0

    i know that something "pop3-related" is running, cause my windows mail client can hit the server successfully... but there is nothing in any mailbox to retrieve.

    so, can anyone help me go about some steps to find out how to get vpopmail to start... or what else is running (from plesk) thats conflicting with its port already being in use.

    thanks a bunch
    jaymer...

    PS _ this has been going on for over 2 weeks - really appreciate the help in getting this sorted
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If I understand you properly, and from the directory paths you posted, let me see if I have this straight:

    You are still running Plesk with the mySQL user table. Or did you dump Plesk totally?

    You uninstalled (rpm -e) the psa-qmail stuff

    You then installed Qmail per LWQ

    You then installed vpopmail per
    http://sourceforge.net/projects/vpopmail/

    You then installed the vpopmail-mySQL to allow vpopmail to use the mySQL database from Plesk (with appropriate changes to pull info from the Plesk tables?) Assuming you are still using Plesk to create mail users...
    http://www.pipeline.com.au/staff/mbowe/isp/vpopmail-mysql.htm

    If any of this is not correct, please clarify since some of your post could allow some incorrect assumptions.

    Plesk does not create/use the structure:
    /home/vpopmail/domains/...
    as vpopmail defaults to.

    Do you still have the Maildir structure at:
    /var/qmail/mailnames/domain.com/
    ??
     
  3. jaymer

    jaymer Guest

    0
     
    hi,
    thx very much for the reply

    apparently, i didn't unintall psa-qmail

    -bash-2.05b$ rpm -q -a | grep qmail
    psa-qmail-1.03-fc2.build75050128.11
    psa-qmail-rblsmtpd-0.70-fc2.build75050128.11
    -bash-2.05b$ rpm -e psa-qmail-1.03-fc2.build75050128.11
    error: Failed dependencies:
    /usr/bin/newaliases is needed by (installed) mailman-2.1.5-7
    smtpdaemon is needed by (installed) mdadm-1.5.0-3
    smtpdaemon is needed by (installed) fetchmail-6.2.5-2
    smtpdaemon is needed by (installed) mutt-1.4.1-6
    psa-qmail is needed by (installed) psa-courier-imap-add-7.5.2-fc2.build75050128.11
    psa-qmail is needed by (installed) psa-7.5.2-fc2.build75050128.11
    psa-qmail is needed by (installed) psa-qmail-rblsmtpd-0.70-fc2.build75050128.11
    /usr/sbin/sendmail is needed by (installed) squirrelmail-1.4.3-1


    but i wouldn't mind doing a force remove on all that **** if it would help


    installed per LWQ: yes, will have to review that to see how far i got before getting stuck

    installed vpopmail from: http://www.inter7.com/vpopmail/install.txt
    and Yes, the vadduser, vadddomain stuff works, as does QmailAdmin.

    i'm not doing ANYTHING related to MySQL , w.r.t. email or any email packages

    yes, there is one user inside there, and it is me. the .qmail-default file was last touched 9 days ago - no other files appear there

    as i say, i think somthing plesk-related is still in effect, cause thats why my pop3d process won't start (per qmailctl stat)
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, as your post shows, there are still Plesk related items still installed.

    If you are trying to get totally away from Plesk, then you should either do a fresh reload of the OS, or you'll have to undo everything you've done to get rid of the deps and then rpm -e the psa items, then re-do everything.

    Kind of like you built the house on an unstable foundation, my opinion would be to tear it all down and build upon a solid foundation, whether it's Plesk or whatever.
     
  5. jaymer

    jaymer Guest

    0
     
    well, aside from the fact that there's stull stuff installed, i'm not sure that i need to deinstall everything to fix my one or two issues.

    1) incoming mail is delivered into a local Maildir instead of into the vpopmail structure? why is that? whats running thats handling it that way. if I could stop that process (or redirect the incoming email) then I've solved that one

    2) and thats prolly related to the existing plesk-pop3 daemon thats allowing me to check email from my windows client. if i can kill it and free up that port, then the qmail pop3d service will start.

    jaymer...
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If you do a netstat -alvpe |grep 'pop3' you should see that probably the psa-courier module (couriertcpd) is listening on the pop3 and pop3s

    And your earlier list shows you still have psa-courier installed.
     
  7. jaymer

    jaymer Guest

    0
     
    i'm not sure if this tells you what you need, but here it is:

    [root]# netstat -alvpe |grep 'pop3'
    netstat: no support for `AF IPX' on this system.
    netstat: no support for `AF AX25' on this system.
    netstat: no support for `AF X25' on this system.
    netstat: no support for `AF NETROM' on this system.
    tcp 0 0 *:pop3 *:* LISTEN root 5795 2865/tcpserver


    i have already modified etc/rc.d/init.d/psa
    to this:
    if [ -e "$vza_file" ]; then
    service="xinetd mysqld"
    else
    service="xinetd named mysqld"
    ## service="xinetd named mysqld qmail courier-imap"
    fi


    I do know that when I used to reboot, I'd have to stop the courier/imap service in the plesk control panel before one of the QMAILCTL services would start - yes, due to the fact that it was using the port.

    But since I installed vpopmail, even doing that doesn't free up the port.

    thx for helping - please stick with me until i can get something resolved!
    jaymer...
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
Loading...