1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Domain Owner backup restore fails

Discussion in 'Plesk for Linux - 8.x and Older' started by BoXie, Jun 14, 2007.

  1. BoXie

    BoXie Guest

    0
     
    System:
    -----------
    - OS : CentOS 4.x
    - Plesk 8.1.1
    - Backups and restores are done (and made) in Plesk 8.1.1
    - IP (shared v.s. exclusive) settings are correct.

    Problem:
    -------------
    When Domain Owners perform a domain restore in Plesk, it fails during virtual hosting re-setup. What is wrong here.

    In particularly the following output is unexpected i guess :

    Code:
    ------------------------------------------------------------------------------------
    2007-06-07 16:49:03,002 INFO Packet succesfully validated.
    2007-06-07 16:49:07,049 INFO Subprocess <subprocess[16006] '/usr/local/psa/admin/sbin/deployer' '--session-path=/srv/backup/psa/tmp/restore_1_4' '--deploy-dump' '--backup-user=xxxxxxxxxx.nl' '--backup-user-type=domain-admin' '--socket-path=/usr/local/psa/tmp/backup-extractor.15997'> was finished with exit code 1
    == STDOUT ====================
    
    == STDERR ====================
    Uncaught std::exception: UnixClientSocket::UnixClientSocket, connect: No such file or directory
    ------------------------------------------------------------------------------------
    
    And in GUI :

    Code:
    2)
    Traceback (most recent call last):
    File "/usr/local/psa/admin/share/supervisor/processor.py", line 115, in doActivityRunner
    newState = self.doActivity()
    File "/usr/local/psa/admin/share/supervisor/processor.py", line 792, in doActivity
    cmd.spawn(os.environ.has_key("PLESKRESTORE_MODE"))
    File "/usr/local/psa/admin/lib/python/subproc.py", line 238, in spawn
    proc.run()
    File "/usr/local/psa/admin/lib/python/subproc.py", line 193, in run
    BaseSubprocess.run(self)
    File "/usr/local/psa/admin/lib/python/subproc.py", line 177, in run
    self.wait()
    File "/usr/local/psa/admin/lib/python/subproc.py", line 197, in wait
    BaseSubprocess.wait(self)
    File "/usr/local/psa/admin/lib/python/subproc.py", line 187, in wait
    raise NonzeroExitException(self, os.WEXITSTATUS(status))
    NonzeroExitException: was finished with exit code 1
    
    More log .. see attachment.
     
  2. ThePhantom@

    ThePhantom@ Guest

    0
     
    i had the same exact problem
    i run plesk 8.2.0 on a CentOS box
    i solved it by update all perl and python packages with yum.
    i also updatet httpd , mod_ssl and mod_perl

    hope this works for all people with the same problem
     
Loading...