1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk giving us hell

Discussion in 'Plesk for Linux - 8.x and Older' started by thunder@, May 15, 2005.

  1. thunder@

    thunder@ Guest

    0
     
    Firstly, it keeps reverting our httpd.conf changes. We allows symbolic links in certain dirs, it removes them every few days. Today though, all of a sudden, no changes, nothing, it removed messed the permissions of every site on our server, changing the CHMOD on httpdocs to 750 instead of 755, we tried to restart plesk and got all sorts of errors, now it settled at this one:
    http://forum.sw-soft.com/showthread.php?s=&postid=105258#post105258
    Something about Dr.Web. So as we stand now we don't know why its reverting config and why plesk wont start, like I said we changed nothing during this period, and had restarted previously uneventfully. Is the software that messed an unstable? We cant keep having our clients sites go out. Its getting very annoying, and now their control panel is out! Anyone have any ideas at getting Plesk up again, and maybe insite on the CHMOD/conf issues (changing on their own). Thanks
    John
     
  2. OhMyGoshJosh

    OhMyGoshJosh Guest

    0
     
    I'm not sure about your Dr. Web issue, but the other problem you describe -- Plesk keeps erasing your changes to httpd.conf -- is not a bug but part of the system design. Plesk describes in their documentation that httpd.conf changes will work if you make them, but that every time the web server is reset, the changes will be reverted back. The solution Plesk offers is to create a vhost.conf file in the same folder where you enter all custom entries. Search google for "vhost.conf" and you'll probably find what you need.
     
  3. thunder@

    thunder@ Guest

    0
     
    Thanks, that explains a lot. Now I jsut need to get plesk up and running. The drweb32,key is nowhere on our box, and we didint delete it, it worked before though.

    And the CHMOD issue. Im fairly certain all this was triggered by adding a new domain, even though it didnt act up till around 30 minutes after setting the domain up.
     
  4. thunder@

    thunder@ Guest

    0
     
    Ok I got plesk up and running, but im still getting permisson erros gallore. When I try to go to logs from in plesk I get:
    LogFilesList->init() failed: filemng failed: filemng: stat failed: Permission denied

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/htdocs/domains/logs/log_files.php:108 psaerror(string "LogFilesList->init() failed: filemng failed: filemng: stat failed: Permission denied")

    Remember, I had to manually set my Httpdocs permissions on all my domains to 775 after plesk reset them all to 750.

    Also my web_users folder isnt serving out. When you go to a webusers folder http://www.domain.com/~user/file.jpg you get:
    Forbidden
    You don't have permission to access /~deadlyz28/101_0285.JPG on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


    --------------------------------------------------------------------------------

    Apache/2.0.51 (Fedora) Server at www.mainstreamtopics.com Port 80

    Any help is greatly appreciated. Thanks,
    John
     
Loading...