1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk - Horde IMP - PHP Issue

Discussion in 'Plesk for Windows - 8.x and Older' started by edesignway, Dec 22, 2005.

  1. edesignway

    edesignway Guest

    0
     
    Hello, I am looking for any suggestions.

    Every time I upgrade to a new revision, the update breaks Horde IMP, usually after some playing around I can get it working... After the 7.5.6 update I am having no luck.

    If you go to http://webmail.domain.com it will load the index.html page, however anything php will not load.

    Below is everything that I have done.


    First I ran the websrvmng.exe --reconfigure-webmail, that did no good.

    Second I deleted webmail from IIS and then ran the above command, no go.

    Next I uninstalled Horde IMP and then reinstalled it through add remove programs, no go.

    I tried deleting webmail from IIS, the vhost dir, and then reinstalling Horde IMP then running the above command... no go.

    Next I tried copying the php.ini file from the horde dir into the main webmail dir, no go.

    Finally I tried copying the php.ini from the windows did over into the webmail and /horde dir, no go.

    Thanks,
    T R
     
  2. swarm

    swarm Guest

    0
     
    It seems you need check if there is mapping for .php, .php3 and .phtml set for horde virtual dir under webmail webmail. If it's not set then add mapping and set php.exe in cgi mode to serve .php scripts.
     
  3. bcsurfer

    bcsurfer Guest

    0
     
    You will also need to edit C:\Inetpub\vhosts\webmail\horde\lib\core.php as follows:

    Change:

    ini_set('include_path', dirname(__FILE__) . PATH_SEPARATOR . ini_get('include_path'));

    To:

    ini_set('include_path', dirname(__FILE__) . PATH_SEPARATOR . ini_get('include_path') . PATH_SEPARATOR . 'C:\Inetpub\vhosts\webmail\horde\pear');

    It worked for me...
     
Loading...