1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk keeps overwritting my Reverse DNS zonefiles (in-addr.arpa)

Discussion in 'Plesk for Linux - 8.x and Older' started by psyxakias, Apr 3, 2005.

  1. psyxakias

    psyxakias Guest

    0
     
    Hello,

    I have been trying to have an external Reverse DNS zonefile (XXX.XXX.XXX.in-addr.arpa) that will be controlled via SSH but Plesk keeps overwritting it. The reason I want to do this is that I want to set PTR records to server's IPs, even if domain is not currently hosted at the server without creating bogus domain names.

    Possible Solutions that do *not* help:
    1) Removing PTR record from System, Server, DNS -- Reason: Already done, but webhosting clients still can accidentally add PTR records manually
    2) Disabling DNS access from General, Client, Limits cannot be done -- Reason: webhosting clients are hosting their domains on the server and I cannot forbid them from controlling their DNS access

    Possible Solutions that do *may* help:
    1) Are there any hidden settings that will prevent Plesk from overwritting Reverse DNS zonefiles?
    2) Are there any hidden settings that will prevent Plesk from editing in-addr.arpa zones in named.conf?
    3) Would it be possible SW-Soft to add a "Reverse DNS: [Enable]/[Disable]" option at "Server, DNS" that will allow/disallow anyone from adding/removing/changing PTR records?

    Any suggestions related to this issue are welcome.


    Best Regards,
     
  2. psyxakias

    psyxakias Guest

    0
     
    I haven't seen any response in the last 8 days, anyone?
     
  3. ross_davis

    ross_davis Guest

    0
     
    Add a Crontab entry like the following that copies a good backup copy of the dns file you want over top of that PSA builds.

    This is what I had to do to stop PSA from breaking my reverse dns

    * * * * * cp /var/named/run-root/var/xxx.yyy.zzz.in-addr.arpa.keep /var/named/run-root/var/xxx.yyy.zzz.in-addr.arpa -f
     
  4. psyxakias

    psyxakias Guest

    0
     
    First of all, I'd like to thank you for replying to my thread even after 1 year ago. I was (and still am) kinda disappointed that nobody seemed to care for a whole year for this issue.

    I'm aware of such crontabbed solution but it doesn't sound ideal to to keep trying who will overwrite RDNS first. I believe it would be much more appropriate to have an option inside the controlpanel to activate/de-activate function for RDNS to prevent this from happening.

    Thanks again for your response and I'd really appreciate if we can hear some response from the official Sw-soft team about it.

    Regards,
     
  5. chickenbak

    chickenbak Guest

    0
     
    What about changing the permissions on it so Plesk doesn't have write capability on the files?
     
  6. psyxakias

    psyxakias Guest

    0
     
    The problem is that it overwrites named.conf records and even if I chflag the file(s) that I don't want it to overwrite, it breaks with a php error while trying to change a DNS record.
     
  7. Who-m3

    Who-m3 Guest

    0
     
    Remove the PTR Record from your DNS Template will prevent this from re-occuring on any new domain creation. Additionally, it'll remove the chance of a client using "Default" to reset their DNS to the template.

    You'll need to go through each domain and remove the PTR Records within. Any PTR records within current DNS records are liable to cause your in-addr zone to reset when any changes are made.
     
  8. psyxakias

    psyxakias Guest

    0
     
    Who-m3,

    I'm aware of this but while having a server with hundreds webhosting domains, it's possible some customer to accidentally add a PTR record (i.e testing it).

    This is why I was trying to figure out if there's a way to completely disable PTR records being set from the panel.

    Thanks.
     
  9. Who-m3

    Who-m3 Guest

    0
     
    You could modify the plesk database in the area of "dns_recs" and remove the PTR record from the options. Plesk would still try to set it (as they have the option hard-coded), but it'd fail to write to the database. I've used this method before to enable IPv6 DNS records (added the option, then manually added the record in the database). Just be aware that you'll have to come back and do it again with each update you apply...Don't you just love how they make sure their database is in place the way they want it each time? :)
     
Loading...