1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Issue Plesk Onyx on Ubuntu - access to mysql remotely

Discussion in 'Plesk Onyx for Linux' started by digitalberg, Jun 1, 2017.

  1. digitalberg

    digitalberg New Pleskian

    4
    70%
    Joined:
    Sep 12, 2015
    Messages:
    13
    Likes Received:
    0
    Hi all,

    We are unable to connect MySql from any third party tools like HeidiSQL and unable to connect from Windows Server 2012 too.

    For your reference following is the connection string of web.config file of Windows Server.

    <add name="ConnMySql" connectionString="Server=62.88.88.80; Port=3306; Database=tdsm;Uid=mas1; Pwd=Dsdsdsd; " providerName="MySql.Data.MySqlClient" />

    For your reference attached the screenshot of third party tools error.

    Also, I have used this instruction but still no luck: How to enable remote access to MySQL database server

    Please advice on this matter.

    Regards
    Q
     

    Attached Files:

  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,405
    Likes Received:
    1,214
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    Are you sure that there is no any specific firewall rules and port 3306 is not firewalled on this server?
    I try to connect to this MySQL server from my server and see following:

    $ telnet 62.88.88.80 3306
    Trying 62.88.88.80...
    telnet: connect to address 62.88.88.80: Connection timed out

    Have you tried this test from your workstation?
     
  3. digitalberg

    digitalberg New Pleskian

    4
    70%
    Joined:
    Sep 12, 2015
    Messages:
    13
    Likes Received:
    0
    Please accept my apologies, the IP address I mentioned is incorrect for security reason :)

    Yes there is no firewall, but I managed to open 3306 port there was a small bug in the ubuntu, however, still struggling to grant access to specific IP from the p.2 : How to enable remote access to MySQL database server

    Still getting the same error: Can't connect to MySQL server on 'server' (10061)
     
  4. AusWeb

    AusWeb Regular Pleskian

    14
     
    Joined:
    Nov 22, 2016
    Messages:
    179
    Likes Received:
    26
    Location:
    Melbourne, Australia
    you have these 3 options when you are creating a database (as admin)

    Access control
    - Allow local connections only
    - Allow remote connections from any host
    - Allow remote connections from

    If you are working on existing database, there is no option to change above options. Idea - you can create a new database with "Allow remote connections from any host" and import the old database.

    Also make sure this is NOT in your my.cnf
    [mysqld]
    bind-address = 127.0.0.1 or localhost
     
  5. UFHH01

    UFHH01 Plesk addicted!

    44
    64%
    Joined:
    Jun 11, 2013
    Messages:
    6,762
    Likes Received:
    1,709
    Location:
    Hamburg / Germany
    Sorry, this statement is incorrect.

    If you desire to change existing privileges, you would login as "admin" over PHPmyAdmin ( => HOME > Tools & Settings > Database Servers - - choose the button/iconPlesk-Onyx_Tools-Settings_Database-Servers_customize.png at the right side of your datbase server ).
    At the PHPmyAdmin - Interface, choose the desired database, go to "Privileges", choose the "global" or "database-specific" action "Edit privileges" and choose there

    => "Login information". ( Don't forget to choose the desired options at the bottom: "Create a new user account with the same privileges and …" after your changes! ;) )
     
  6. digitalberg

    digitalberg New Pleskian

    4
    70%
    Joined:
    Sep 12, 2015
    Messages:
    13
    Likes Received:
    0
    Thanks all,

    Highly appreciate your help here.

    I will check as you mentioned and let you know the outcome.

    Regards
     
Loading...