1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk screwing up httpd.include - some sites not working by IP address

Discussion in 'Plesk for Linux - 8.x and Older' started by kevin@, Feb 24, 2006.

  1. kevin@

    kevin@ Basic Pleskian

    24
    23%
    Joined:
    Nov 30, 2001
    Messages:
    50
    Likes Received:
    0
    PSA 7.5.4
    FreeBSD 5.3

    Plesk keeps messing up my httpd.include file and putting half of my sites at the top of the file where they should be - so they will work if you enter http://xxx.xxx.xxx.xxx/ but the other half are being stuck at the end of the file so http://xxx.xxx.xxx.xxx/ results in the Plesk default page.

    I try to change it till my heart's content, but plesk always messes it up again.

    What can I do?

    The follow is what is being stuck in at the bottom of httpd.include, instead of at the top:

    </IfModule>

    Include /usr/local/psa/home/vhosts/xxx.ca/conf/httpd.include

    Include /usr/local/psa/home/vhosts/xxx.com/conf/httpd.include

    Include /usr/local/psa/home/vhosts/xxx.nu/conf/httpd.include

    Include /usr/local/psa/home/vhosts/xxx.com/conf/httpd.include

    <VirtualHost xxx.xxx.xxx.xxx:80>

    Thanks
     
  2. kevin@

    kevin@ Basic Pleskian

    24
    23%
    Joined:
    Nov 30, 2001
    Messages:
    50
    Likes Received:
    0
    Any ideas?

    It is really annoying how Plesk put half of these includes in the proper place, and half where they would not work properly.

    I'm at a loss here! How can I edit these?
     
Loading...