1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Post fix port 587

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by juandelmoralito, Oct 20, 2010.

  1. juandelmoralito

    juandelmoralito New Pleskian

    22
    73%
    Joined:
    Feb 17, 2009
    Messages:
    18
    Likes Received:
    0
    I just reinstalled the SO with plesk included + postfix.
    The master.cf comes without the submisson line:

    smtp inet n - - - - smtpd -o smtpd_proxy_filter=127.0.0.1:10025
    # -o smtpd_enforce_tls=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps inet n - n - - smtpd
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #628 inet n - n - - qmqpd

    I added it:
    submission inet n - - - - smtpd -o smtpd_proxy_filter=127.0.0.1:10025

    Then I restart the service:
    service postfix restart
    and everything goes right

    Problems comes when I restart the service through the plesk panel
    them the submission line disappear
    Same thing occurs every night with the graceful restart
    The plesk rewrite the master.cg but without the submission line.
    I reinstall the postfix but same problem.
    What can I do with that extraordinary Plesk.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Why you can't use Enable message submission check box to allow your customers to send e-mail messages through the port 587 as it is described in Administration Guide?
     
  3. esbon

    esbon Basic Pleskian

    24
    23%
    Joined:
    Sep 16, 2006
    Messages:
    66
    Likes Received:
    0
    If I click on Enable message submission does this mean the postfix server will stop working on port 25?

    Thanks
     
  4. esbon

    esbon Basic Pleskian

    24
    23%
    Joined:
    Sep 16, 2006
    Messages:
    66
    Likes Received:
    0
    Is this supposed to work with Postfix? It does work with qmail!
     
Loading...