Issue post issues after wordpress site has been copied and removed original subscription from plesk onyx

Discussion in 'Plesk Suggestions and Feedback' started by Noturns, Dec 15, 2016.

  1. Noturns

    Noturns Regular Pleskian

    14
    35%
    Joined:
    Jul 20, 2014
    Messages:
    168
    Likes Received:
    7
    centos 6.5
    plesk onyx 17.0.17

    Today i have successfully copied a predicated site to a sub domain of an existing subscription.
    After redirecting to wordpress website i decided to remove the predicated original subscription from Plesk.

    For some reason it also removes the original wordpress database.
    I would have thought that Plesk wizard automatically copy and create a new wordpress database.

    Options i have tried myself:
    - Backup Manager > recover Database of removed (predicated) domain
    which resulted in Error: Some objects cannot be restored because they belong to the following domains that are not found in Plesk

    What is the best way to fix this removed database?
    May i suggest to make additional options like would you like to original website to be moved instead of copied?
     
    Last edited: Dec 15, 2016
  2. Noturns

    Noturns Regular Pleskian

    14
    35%
    Joined:
    Jul 20, 2014
    Messages:
    168
    Likes Received:
    7
    There seems to be a Plesk > wordpress database relation problem. Specifically after a subscription was removed after the copy process. The original database which was deleted would always contain the old database name. Which results in database not found.

    I've got a backup of the database. I have uploaded this to an existing domain. I wish to be able to rename this database and connect it somehow to the correct wordpress application. Also for some reason i'm not able to rescan this wordpress application. In the current build i cannot rename the database because of user restrictions.
     
  3. Danilo Schwabe

    Danilo Schwabe New Pleskian

    5
    20%
    Joined:
    Tuesday
    Messages:
    14
    Likes Received:
    1
    Location:
    Berlin
    What build are you on right now? Can you update to Plesk 17.5 (should be available as stable now) and test via Wordpress Toolkit again?
    I use this system myself, but never removed the original subscription before. Would be interessting to know if this is really a bug.
     
  4. UFHH01

    UFHH01 Platinum Pleskian Plesk Guru

    40
    64%
    Joined:
    Jun 11, 2013
    Messages:
    4,905
    Likes Received:
    1,014
    Location:
    Hamburg / Germany
    Hi Danilo Schwabe,

    I tested the described issue and can't confirm it as an existing bug ( not at 17.0.17, nor at 17.5 ).
     
  5. Danilo Schwabe

    Danilo Schwabe New Pleskian

    5
    20%
    Joined:
    Tuesday
    Messages:
    14
    Likes Received:
    1
    Location:
    Berlin
    Thanks for taking the time to test it! Good to know! :)
     
Loading...