1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Preview a site problem - before and after DNS has been set

Discussion in 'Plesk for Windows - 8.x and Older' started by TheFOX, Aug 15, 2004.

  1. TheFOX

    TheFOX Guest

    0
     
    There is a special preview button in the Plesk interface... I imagine that it should be used to see the site even before the DNS has been set..??? Right or wrong..???

    Ensim also has this feature and here it posible to preview a site when is is being developed. I just create the site in the administration panel and preview it with the IP adress followed by the domain name.

    If I do the same in plesk the url looks very similar: IP adress/domain name
    http://XXX.XXX.XXX.XXX/domain.com
    but I get this message no matter if the DNS is set or not:

    Not Found
    The requested document was not found on this server.

    So Preview just don't work for me...

    Any ideas..???
     
  2. jaytee

    jaytee Guest

    0
     
    Probably IIS is looking for executable named domain.com.

    Try adding trailing slash to the URL - http://XXX.XXX.XXX.XXX/domain.com/

    Changing execute permissions on default web site to"Scripts only" might also help.
     
  3. addstravel

    addstravel Guest

    0
     
    I have the same issue with the preview functionality. Adding the '/' doesn't resolve the problem unfortunately.

    Bit frustrating, am finding issues with Plesk 7 (along with Fox it seems, :confused: )
     
  4. TheFOX

    TheFOX Guest

    0
     
    Still no solution

    Nice to know that I'm not alone with my problems... then I cann't be all crazy ;-)

    I have tried it with the / in the end, but still no luck...

    Changing execute permissions on the default web site to "Scripts only"..??? Why should that help with the problem... And can I change that from inside Plesk or..?
     
  5. jaytee

    jaytee Guest

    0
     
    Re: Still no solution

    Seems that preview functionality has a bug that prevents it from working right if the site is set as a default for a given IP address. However, if this is the case, then simple access to http://<ip_address> should work.

    As to changing execute permissions on the default site, it will help if your IIS is thinking that /domain.com is the name of the executable file (.com, .exe, .bat, etc). That's why it might help in some cases.
     
  6. Nivahost

    Nivahost Guest

    0
     
    Hello guys,

    Turn Off your firewall in plesk and the preview will work for your domains. Or if you have a additional firewall installed on your server like: Visnetic etc. Try to disable the firewall and see if the preview button will work. Let me know.

    Regards,
    Henry
     
  7. nyotron

    nyotron Guest

    0
     
    I have the same issue, seems like Plesk doesn't much care.

    I'v already sent an email for this issue, and it been 2 days, and i never got replied.

    this issue is *very* imptrotant for me, I have lots of clients to add and no on seems to offer a decent solutions that will work.

    No firewalls is running and the "/" thing is not much helping.
     
  8. Freebyrd

    Freebyrd Guest

    0
     
    I too have the same damn problem!
     
  9. wendat

    wendat Guest

    0
     
    Re: Re: Still no solution

    Yes exactly
    The first installed site was set as default to IP.
    Then we changed it as a share IP and still we get that default site locked to the IP address and no "preview site" icons works as well. Very annoying.
    How can it be fixed?


     
  10. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    the answer is as wendat has written in another post to remove the default web site, if not possible within plesk from IIS. If anyone needs help with this I would gladly help
     
Loading...