1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with DNS bind

Discussion in 'Plesk for Windows - 8.x and Older' started by mada@, Nov 9, 2006.

  1. mada@

    mada@ Guest

    0
     
    I'm currently running Plesk 7.6 on a Windows 2003 Godaddy Virtual Dedicated Server. Whenever I add, modify or delete a domain or subdomain my server dies and looses the ability to resolve domains.

    The system automatically edits named.conf (in C:\SWSoft\Plesk\dns\etc) and adds the following line of code at the top:-
    Code:
    include "C:\SWSoft\Plesk\dns\etc\named.user.conf";
    In order to get the server to come back online I have to delete or comment out the include line then restart plesk. Obviously this is driving me insane and I would love to resolve it. Here are the files in question (when the server is working):-

    named.conf
    Code:
    key "rndc-key" {
    	algorithm hmac-md5;
    	secret "q3WX4YxhrNF9F/WECMlYiA==";
    };
    
    acl common-allow-transfer {
    		none;
    		};
    named.user.conf (Which the code the system adds includes)
    Code:
    options{ 
    allow-recursion	 {localnets; }; 
    };
    
    Does anyone have any ideas?
    :confused:
     
  2. Timbuck2

    Timbuck2 Guest

    0
     
    I have the same issue

    I recently activated a virtual server with Godaddy.
    I added a domain for my nameserver and a domain to test with.
    My name server wouldnt start up. So I opened
    named.conf and remmed the following line.
    include "C:\SWSoft\Plesk\dns\etc\named.user.conf";
    Everything started working. After a short while it stopped. Plesk Name Server wouldnt start.
    I found that the include line had been prepended back in to the file.
    I remmed it out again and Remmed every line in
    C:\SWSoft\Plesk\dns\etc\named.user.conf
    Again everything started working. After a short while it stopped again.For the same reason.
    A Goddy rep had called just to check on me and I explained the problem. He had me delete my name server domain and add it back and leave everything as default.
    It didnt work. However if I follow the same procedure as above I can get it working again.

    Here are the first part of the File Contents of named.conf
    include "C:\SWSoft\Plesk\dns\etc\named.user.conf";
    #include "C:\SWSoft\Plesk\dns\etc\named.user.conf";

    # removed by 11/16/06
    # see named.user.conf for details
    #include "C:\SWSoft\Plesk\dns\etc\named.user.conf";




    Here are the File Contents. of named.user.conf it had an options block

    # this file and directive is no longer in use. see below notes.

    #options {
    # allow-recursion {localnets; };
    #};


    # this options block breaks the standard conf
    # named cannot handle two options blocks within the same conf
    # there is a pre-exisiting options block within the rndc.conf
    # the named.user.conf file is included from within named.conf
    # rndc.conf is included into the named.conf by default
    # I transferred this option to allow dns recursion to localnets only
    # into the options block within rndc.conf
    ## 11/16/06

    Here is the options block in rndc.conf
    options {
    default-server localhost;
    default-key rndc-key;
    allow-recursion {localnets; };
    };
     
  3. Timbuck2

    Timbuck2 Guest

    0
     
    My temporary Fix Name server wont start

    placed this
    allow-recursion {localnets; };
    in rndc.conf

    created a named.user.conf file with absolutely nothing in it

    left the include named.user.conf line in
    named.conf

    So far this seems to work.
    Before when remming the include in named.conf I had only to go thru plesk -> domains -> select a domain -> DNS at some point in that process the include prepended back into named.conf and the named service would stop.

    With the above change so far the named service continues to run. I'm still curious as to what the problem is.

    The application event log clearly shows
    C:\SWSoft\Plesk\dns\\etc\named.conf:21: 'options' redefined near 'options'

    unless you empty user.conf or find a way to stop the include I dont see an easy solution.

    because its in rdnc.conf and named.user.conf so I dont know what the deal is here. Anyone have a clue. I know the folks at Godaddy are looking into it.
     
  4. mada@

    mada@ Guest

    0
     
    Tim,

    Your solution does appear to work!

    Many Thanks
    Adam Beizsley-Pycroft
     
  5. Timbuck2

    Timbuck2 Guest

    0
     
    It looks that way

    Greets Mada.
    My name service stayed up all night. The server Athena seems stable although I'm not. Little to no Sleep.

    I've provided Godaddy with a link to this thread and informed them that u also are having this problem. I'll let you know if they provide any new info.

    I've been muttering words similar to the names of several of the threads in your forums @ voltagerock #$@%$#%$# :)
     
  6. EricAtETC

    EricAtETC Guest

    0
     
    Awesome -- this same problem on my new GoDaddy virtual server had me pulling my hair out.

    Thanks for the solution!! :)
     
Loading...