1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Problem with FTP - Sometime can, sometime cannot

Discussion in 'Plesk for Linux - 8.x and Older' started by boliao, Oct 10, 2005.

  1. boliao

    boliao Guest

    0
     
    Hi there,

    I have a very irritating problem with my FTP on Plesk 7.5.4

    My server is running behind a hardware firewall and I've configure the firewall to allow port 21.

    In my server I have AFP and I've allow the software firewall to allow the following port to open for the Passive 30000 50000

    For my proftpd.include i've set as follow.

    ServerName "ProFTPD"
    ServerType inetd
    ServerType inetd
    DefaultServer on
    UseReverseDNS off
    <Global>
    DefaultRoot ~ psacln
    AllowOverwrite on
    IdentLookups off
    PassivePorts 30000 50000
    </Global>
    DefaultTransferMode binary
    UseFtpUsers on

    # Port 21 is the standard FTP port.
    Port 21
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask 022

    # To prevent DoS attacks, set the maximum number of child processes
    # to 30. If you need to allow more than 30 concurrent connections
    # at once, simply increase this value. Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances 30

    #Following part of this config file were generate by PSA automatically
    #Any changes in this part will be overwritten by next manipulation
    #with Anonymous FTP feature in PSA control panel.

    #Include directive should point to place where FTP Virtual Hosts configurations
    #preserved

    ScoreboardFile /var/run/proftpd/scoreboard

    # Primary log file mest be outside of system logrotate province

    TransferLog /usr/local/psa/var/log/xferlog

    #Change default group for new files and directories in vhosts dir to psacln

    <Directory /var/www/vhosts>
    GroupOwner psacln
    </Directory>

    # Disable PAM authentication
    AuthPAM off

    my problem is sometime I can upload file to the server using a client ftp (WSFTP, Cute FTP and so on) but sometime I can't upload at all. They will give me timeout.

    I've try this in my office and at home and still get the same problem...... and yes, I've try on different computer, using different FTP client..... sometime can upload files, sometime it just got hang and timeout. I've also asked my friends to give it a try and get the same problem, some people can, some people cannot and worst, those people who can previously, when they use another account, they can't upload!

    Btw, I've tried on different ISP too and still face with the same problem........

    anyone can tell me what is wrong? because I'm totally lost now.....

    if it didn't work at all, that would be easier to solve but when it is intermittent like this, I'm so lost.......

    :confused: :confused:
     
  2. boliao

    boliao Guest

    0
     
    latest update.......

    I try 3d FTP and have no problem uploading files...... i ask few of my friends to use 3d FTP and test and they too do not have problem uploading files......

    it seem that 3d FTP will keep on sending "Keep Alive" command, which other FTP client do not do unless you manually set them............

    Can I safely say it is a timeout problem... because if you send large files it will hand...........

    but the problem is, why sometime can sometime cannot? AHHHHHH
     
  3. tonycaso

    tonycaso Guest

    0
     
    I have exactly the same problem.

    but I can connect after 10 minutes waiting, and in each directory I wat to get in, I need to wait about 10 minutes again.

    The most dificult directory to get in , is httpdocs.

    sometimes I can upload, sometimes it spends a lot of time waiting for the list, and sometimes I lost connection.

    any burning brain?

    :confused:
     
  4. tonycaso

    tonycaso Guest

    0
     
    Help please, I need ftp working at all.
     
  5. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    I had a firewall that would not allow using PASV mode. Try setting your clients to ACTIVE mode and see if that makes any difference.
     
  6. tonycaso

    tonycaso Guest

    0
     
    no difference:(
     
Loading...