1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with Login

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by Planck, Jun 3, 2011.

  1. Planck

    Planck Guest

    0
     
  2. Planck

    Planck Guest

    0
     
    I'm trying to disable SSO (http://kb.odin.com/en/9327) but i get the following message:

    -------

    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.[Window Title]
    C:\Program Files (x86)\Parallels\Plesk\admin\bin\php.exe

    [Content]
    C:\Program Files (x86)\Parallels\Plesk\admin\bin\php.exe is not a valid Win32 application.


    [OK]
     
  3. PavelV

    PavelV Plesk for Windows Staff Member

    28
     
    Joined:
    Nov 15, 2010
    Messages:
    251
    Likes Received:
    15
    Original issue can be if your hostname cp.***.gr is not resolved from your server.

    You can also check sso log for any errors here:
    %plesk_dir%\admin\logs\sso.log

    regarding KB article, which command exactly you have tried to execute? Is file php.exe exist? which size of this file?
     
  4. WilcoW

    WilcoW New Pleskian

    20
     
    Joined:
    Jul 22, 2009
    Messages:
    18
    Likes Received:
    0
    Same problem here, everything was working fine. Installed SSL certificate, loged out and in again, worked fine, ssl worked also. After server restart, it started looping before login screen came up. https://wintsvrtx.eu:8443

    Any idea how can I solove this?
     
  5. PavelV

    PavelV Plesk for Windows Staff Member

    28
     
    Joined:
    Nov 15, 2010
    Messages:
    251
    Likes Received:
    15
    SSL certificate used for Panel reused by SSO. This is not very good, and this can bring you to some troubles, if certificate will be updated in future, so proper way is to generate new certificate for SSO, put them in separate file, and repair connection between Plesk (in order to use new certificate). You can do this using following steps:

    1) generate new certificate:
    "%plesk_bin%\openssl.exe" req -x509 -nodes -days 3650 -newkey rsa:2048 -set_serial 16574823 -keyout "%plesk_dir%admin\conf\sso\sso-cert.pem" -out "%plesk_dir%admin\conf\sso\sso-cert.pem" -config "%plesk_dir%admin\conf\openssl.cnf" < "%plesk_dir%\admin\conf\sso\openssl.input"

    Ensure, that %plesk_dir%admin\conf\sso\sso-cert.pem is generated after this command.

    2) write new certificate to sso config. Open %plesk_dir%\admin\conf\sso\sso_config.ini and put path to new certificate in parameter
    cert_file ="C:\Program Files (x86)\Parallels\Plesk\admin\conf\sso\sso-cert.pem"

    Note: please do not change CA certificate option.

    3) repair connection between billing, plesk and sso in order to start using new certificate.
    %plesk_bin%\billing-repair-integration.exe --command=repair-sso

    After that you should have resolved infinite loop problem.

    Please ask if you still have any issues.
     
  6. WilcoW

    WilcoW New Pleskian

    20
     
    Joined:
    Jul 22, 2009
    Messages:
    18
    Likes Received:
    0
    At start I created a new (Go Daddy) SSL certificate in Plesk, did not change or edit the default certificate.

    I enclosed a screenshot of the SSL certificates in IIS.

    I followup your steps (corrected the paths)

    1)%plesk_dir%\admin\conf\sso\sso-cert.pem is already in the folder

    Executed: "%plesk_bin%\openssl.exe" req -x509 -nodes -days 3650 -newkey rsa:2048 -set_serial 16574823 -keyout "%plesk_dir%\admin\conf\sso\sso-cert.pem" -out "%plesk_dir%\admin\conf\sso\sso-cert.pem" -config "%plesk_dir%\admin\conf\openssl.cnf" < "%plesk_dir%\admin\conf\sso\openssl.input"

    Quick CMD box, nothing happened

    2) cert_file ="C:\Program Files\Parallels\Plesk\admin\conf\sso\sso-cert.pem" is already in file

    3) %plesk_bin%\billing-repair-integration.exe --command=repair-sso nothing happens
     

    Attached Files:

  7. PavelV

    PavelV Plesk for Windows Staff Member

    28
     
    Joined:
    Nov 15, 2010
    Messages:
    251
    Likes Received:
    15
    which version of Plesk do you have?
     
  8. WilcoW

    WilcoW New Pleskian

    20
     
    Joined:
    Jul 22, 2009
    Messages:
    18
    Likes Received:
    0
    Plesk 10.3.1 incl. all mu's
     
  9. ChristosS

    ChristosS Guest

    0
     
    same here after 10.3.1 upgrade the login panel redirects to hostname.local:8443/relay
    tried
    [root@opteron bin]# ./billing-integration --command repair-all --hostname www.mydomain.com --idp_url https://www.mydomain.com:8443
    PHP Fatal error: Uncaught exception 'Zend_Console_Getopt_Exception' with message 'Option "idp_url" is not recognized.' in /usr/local/psa/admin/plib/Zend/Console/Getopt.php:757
    Stack trace:
    #0 /usr/local/psa/admin/plib/Zend/Console/Getopt.php(721): Zend_Console_Getopt->_parseSingleOption('idp_url', Array)
    #1 /usr/local/psa/admin/plib/Zend/Console/Getopt.php(693): Zend_Console_Getopt->_parseLongOption(Array)
    #2 /usr/share/plesk-billing/integration.php(224): Zend_Console_Getopt->parse()
    #3 /usr/share/plesk-billing/integration.php(46): handle_upgrade()
    #4 /usr/share/plesk-billing/integration(3): include_once('/usr/share/ples...')
    #5 {main}
    thrown in /usr/local/psa/admin/plib/Zend/Console/Getopt.php on line 757

    can you please tell us what to do to fix that redirect to /relay??? please??
     
  10. Plesk_kidv

    Plesk_kidv Guest

    0
     
    Try accessing the control panel from remote desktop or try the non-secure port 8880. Once in, go to your Customer & Business Manager panel and change the hostname of the server to a valid hostname. I believe you can change this to the IP address of the server too.
     
Loading...