1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with Virtual Host Template

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by sascha.h, Aug 26, 2010.

  1. sascha.h

    sascha.h Guest

    0
     
    I tried to create a virtual host template for upcoming domains on my own. Almost everything worked fine until I created a new domain, because all files in the created structure have the same, but wrong permissions. In the file browser of the virtual host template everything is correct.

    Any ideas?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Do you mean skeleton? When physical hosting is created these files are copied from skeleton, by default it is $HTTPD_VHOSTS_D/.skel/0/
     
  3. sascha.h

    sascha.h Guest

    0
     
    Hi Igor,
    yes I think it's the skeleton. It's on the Start Page of Plesk and called "Virtual Host Template". So I did my own skeleton, zipped and uploaded it. And everything was fine. Even the permissions of all files. Then I tried to create a subdomain, which worked almost properly, but every file has had 755 as permission. Did I made a mistake?
     
  4. sascha.h

    sascha.h Guest

    0
     
    Hi Igor,
    did you have any answers for me? Thanks in advance.

    Regards,
    Sascha
     
Loading...