1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

problematic access to subdomain

Discussion in 'Plesk 11.x for Linux' started by foulquesd, Nov 9, 2012.

  1. foulquesd

    foulquesd New Pleskian

    10
    35%
    Joined:
    Oct 22, 2012
    Messages:
    5
    Likes Received:
    0
    Hi there,

    First the situation. I recently installed a SVN on my server (working under CentOs6) and I want to access it from the url svn.mydomain.com . It seems that I can access it in http (haven't tried to really use it but I access the revision 0 with the browser), but if I use https I have the apache2 test page (by default when you don't have any files on the domain).
    I searched with google where my configuration wasn't good but I couldn't find it. If any of you has an idea. If you have a question or need any specific detail I'll be happy to answer.
     
  2. DaveKay

    DaveKay Regular Pleskian

    17
    85%
    Joined:
    Jan 2, 2012
    Messages:
    226
    Likes Received:
    0
    Ensure SSL support is enabled under subscription hosting settings. If it is, try reconfiguring vhosts with the following under an SSH session.

    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
     
  3. foulquesd

    foulquesd New Pleskian

    10
    35%
    Joined:
    Oct 22, 2012
    Messages:
    5
    Likes Received:
    0
    Thanks Dave, even if in the end I had to search all the day for the answer.

    Even if your answer isn't the solution it helps as I had to change the configuration of the domain.

    For the ones who could have the same problem, the answer is that tutorial on the net talk only about the vhost.conf file to create (or modify). But the fact is that plesk doesn't call this file when you use https, it calls vhost_ssl.conf. So you just have to write the same lines in this vhost_sll.conf and execute "/usr/local/psa/admin/sbin/httpdmng --reconfigure-all".
     
  4. DaveKay

    DaveKay Regular Pleskian

    17
    85%
    Joined:
    Jan 2, 2012
    Messages:
    226
    Likes Received:
    0
    Glad you fixed your problem!
     
Loading...