1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

problems switching physical hosting IP

Discussion in 'Plesk for Linux - 8.x and Older' started by daffoml, Apr 10, 2008.

  1. daffoml

    daffoml Guest

    0
     
    I have a client that wants to do SSL on their site, so I added another IP to the box, set it to be exclusive, and setup the SSL cert to that IP.

    I go into the domain, choose setup hosting, and switch the IP address to the exclusive one.

    After I click OK, the domain shows all is fine within plesk, but if I try to surf to the site, I get

    If you see this page it means:
    1. hosting for this domain is not configured
    or
    2. there's no such domain registered in Plesk

    Any ideas?

    If I try to put it back to the original IP, it still doesn't work.
    I had to restore the domain from backup in order to restore the site.

    Thanks
     
  2. faris

    faris Guest

    0
     
    You might just need to restart Apache after doing it. It might also be sensible to make the domain the default domain for that IP?

    I'm just guessing I'm afraid.
     
  3. dash

    dash Regular Pleskian Staff Member

    28
    40%
    Joined:
    Sep 26, 2007
    Messages:
    204
    Likes Received:
    47
    The possible reason of the issue is that your domain name is still resolved to another(old) IP address.
    Check that the domain is resolved to exactly IP that is specified in apache config file /var/www/vhosts/<domain>/conf/httpd.include:
    <VirtualHost <IP>:443>
    ServerName <domain>:443
     
  4. daffoml

    daffoml Guest

    0
     
    Faris: Tried that, no change.

    dash: I looked there, any everything appeared ok, this box also handles the DNS for the domain, and before I started all of this, I cranked the SOA timers down so the changes would happen in a couple minutes, so it's not a DNS problem. I am stumped.

    A really odd part is, I have switched domains to new addresses numerous times, and have never had a problem.

    I have tried changing the IP during the restore (IP mapping) but that doesn't work either.

    What other apache files could I look at?

    Thanks for trying to help!
     
  5. daffoml

    daffoml Guest

    0
     
    Well, this is how I got around the problem, I won't say I fixed it.

    I backed up the domain, deleted the domain, then restored the domain, mapping the domain the new address.

    I have no idea why that domain was such a pain, I've now moved the remaining 5 to the new IP without incident. So in total, I have 52 = no problems, 1 big problem.
     
  6. 64bithost.com

    64bithost.com Regular Pleskian

    25
    57%
    Joined:
    Jul 30, 2007
    Messages:
    182
    Likes Received:
    0
    You are gonna hate this answer

    There are three ways to resolve this problem. None are pretty:

    1st:

    Push the reboot button next to the shutdown button on the PLESK interface.

    NOW!!! I said the REBOOT button not the SHUTDOWN button.

    2nd:
    if you have shell access enter SSH.

    type the following

    root@myserver ~]# vzlist -a
    you will get
    CTID NPROC STATUS IP_ADDR HOSTNAME
    1 86 running 209.xxx.xxx.xx ServiceCT
    101 58 running 209.xxx.xxx.xx plesk1.mydomain.com
    110 59 running 209.xxx.xxx.xx plesk2.mydomain.com

    pick the container [CTID] that corresponds to your plesk server where the domain in question is located. Enter the following line of code

    root@myserver ~]# vzctl stop 110

    Now wait patiently. This will happen

    Stopping Container ...
    Container was stopped
    Container is unmounted
    root@myserver ~]#

    Then do this.
    [root@myserver ~]# vzctl restart 110
    Restart Container
    Starting Container ...
    Container is mounted
    Setup slm memory limit
    Setup slm subgroup (default)
    Setting devperms 20002 dev 0x7d00
    Setup ioprio: 7
    Adding IP address(es): 209.xxx.xxx.xxx
    Hostname for Container set: plesk2.myserver.com
    File resolv.conf was modified
    Container start in progress...

    [root@myserver ~]#
    Go back into plesk and double check the I.P. address and then wait 5 minutes for propigation given your HOST/ISP Provider. Double check the domain.

    That is what you do when you have lots of PLESK servers and don't want to reboot the server.

    3rd:

    Just type this at SSH Prompt
    [root@myserver ~]# shutdown -r now

    wait 5 minutes and then see the paragraph above.

    -Chris
     
Loading...