1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems with fsockopen in php to do a whois on port 43

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by jaimet, Feb 11, 2010.

  1. jaimet

    jaimet Guest

    0
     
    Hi,

    I'm trying to execute a PHP script on a plesk 9 server. The main point of the script is to execute a socket request to whois.crsnic.net so i can check if a domain is available or not.

    When i execute the script on my computer, everyting works fine; but when doing it on the server i get a connection timed out error message.

    So i think that my server is blocking the requests i do with this script on port 43. I've tried to setup the plesk firewall, opening the port but still the same. Maybe i'm doing soemthin wrong...

    Is this a firewall problem?

    Php?

    Other?

    I'm desperate.
     
  2. deeplist

    deeplist Guest

    0
     
    Sorry to bring this thread up from the dead, but I am experiencing the same issue. Can anybody else shed some light on this? The same script works on a different server just fine. Port 43 IS open on the trouble machine.
     
Loading...