1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems with mail

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Nunners, Nov 20, 2009.

  1. Nunners

    Nunners Guest

    0
     
    Ok, let me first explain the setup, cos it's not straight forward...

    Our Plesk server has the main domain noahsarkdaynurseries.co.uk. The users on the domain are setup as forwarding accounts, and forward to addresses on a secondary domain nadn.co.uk. That domain is actually hosted by a mailserver within out network, and has a firewall setup so that it only receives email from the plesk server (IP address blocking). This server then spam checks again, and forwards it onto our Exchange server, again on the local domain. Spam checking is turned on on the plesk server, as indeed it is on the local mailserver - it carries out a double check, and actually works really well!

    Since around lunchtime today, we're not getting any emails through and I can't work out why. Sending one from outside of the network comes back with the error:
    That was sent from yahoo's webmail client, and is fairly good at checking things.

    I've checked all connectivity, and indeed turned on the mailbox for the above account, and it starts receiving into the mailbox, but just using the mailforwarding doesn't work.

    Can anyone suggest why? Nothing has changed, as far as I know, and there's nothing to suggest a problem in the logs...

    Any help or suggestions will be gratefully received...

    Thanks
    James
     
  2. Nunners

    Nunners Guest

    0
     
    Getting this drilled down a little further. It would seem that for some reason the domain is not in the /var/qmail/control/rcpthosts file. When adding it, you get a bounce back:
    I'm therefore guessing that somehow the domain has been "wiped" from qmail, and I may need to reset the whole domain. Does anyone know how to go about that, without having to delete the whole lot and start again?!!!

    Thanks
    Nunners
     
  3. Nataliya Zagr

    Nataliya Zagr Regular Pleskian

    21
    87%
    Joined:
    Apr 14, 2009
    Messages:
    242
    Likes Received:
    0
    Hello,

    If you get the bounce message with such error when send mail to a domain hosted on the Parallels Plesk Panel server, then make sure that the Mail service for this domain is enabled and the domain name is listed in $QMAIL_ROOT_D/control/virtualdomains and $QMAIL_ROOT_D/control/rcpthosts files.
    If not, use $PRODUCT_ROOT_D/admin/sbin/mchk utility to rebuild Qmail configuration.

    Please, see the following article for more information:

    http://kb.odin.com/en/168

    When you see the error "I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file", it may happen because of several reasons:

    - domain really does not exist in Plesk, but domain's DNS points to your server as domain's MX,
    - domain exists but domain.com > Mail > Disable option was chosen in the Plesk interface,
    - domain exists and domain was added to above files but qmail failed to restart after it (qmail reads these files during start only),
    - domain exists but domain was not added to the above files because of some failure during domain creation or the files were modified manually. Please, check the following article for the resolution of the problem:

    http://kb.odin.com/article_22_1380_en.html

    Thank you
     
  4. Nunners

    Nunners Guest

    0
     
    Thanks for your reply, and I wish I'd read it before taking the advice of the hosting company... which was the quickest fix would be to remove the domain and start again, which when there's 5 databases and quite a lot within the website that needs reinstalling after, wasn't the best option for me!

    I'll remember your fix though if it happens in future!

    Thanks
    Nunners
     
Loading...