• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

ProFTPd connections stops working - Plesk 10.4.4 Update #40

RinkeB

New Pleskian
Hello,

I have a strange problem with FTP connections to a Plesk server running ProFTPd on CentOS. The problems occurs on various times. When i connect to the server it goes well but then after a couple of seconds/minutes (random) it stops working an the connection is being reset/stopped.

The problem occurs on various systems connecting trough FTP. Firewall 21 is open. When i restart xinetd it seems to be working for a couple of minutes and then the problems keep coming back.

See content of xfertrace in attachment, this is a copy of when the connection was being reset after i opened test.php en tried to save it back trough FTP (Zend PHP IDE):

Can someone help me any further?
 

Attachments

  • ftp-error-tracelog.pdf
    30.1 KB · Views: 5
Coolcap, yes that works as expected:

user@server:~$ telnet localhost 21
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 ProFTPD 1.3.3e Server (ProFTPD) [127.0.0.1]
 
Abdi, the /etc/hosts file is not touched its default:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6
 
Back
Top