1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

psa-spamassassin qmail-scanner gone

Discussion in 'Plesk for Linux - 8.x and Older' started by youngnovice, Nov 25, 2005.

  1. youngnovice

    youngnovice Guest

    0
     
    Could someone help me.

    I actually called myself updating spamassassin and for some reason was looking at rpm -e spamassassin and now when I run yum update psa-spamassassin I receive no packages to update and also qmail-scanner is gone.

    I'm young and learning.. please forgive me. I know I should have looked into it more. :rolleyes:

    I have only a couple of clients but I would like to get it back to working. The Spamassassin is greyed out in the server admin and also is now saying the component is not installed.

    Any help would be greatly appreciated.


    Thank You
     
  2. youngnovice

    youngnovice Guest

    0
     
    also tried

    I also tried using atomic but was unable to get psa-spamassassin via yum only spamassassin was available it said via ssh.
     
  3. ShadowMan@

    ShadowMan@ Guest

    0
     
    You posted that you did a 'rpm -e spamassassin', this is the main spamassassin application package (different than psa-spamassassin) so to re-install it, do:

    yum install spamassassin

    Then for the Plesk control interface to spamassassin (psa-spamassassin):

    yum install psa-spamassassin

    After that, as long as you didn't uninstall qmail-scanner, then all you should have to do is:

    /usr/bin/qmail-scanner-reconfigure

    However, if for some reason the qmail-scanner package actually got uninstalled as well, then just reinstall it next:

    yum install qmail-scanner

    Then run the /usr/bin/qmail-scanner-reconfigure

    You obviously have SSH login to have been able to do the original 'rpm -e' command, so I won't go into using that.
     
  4. youngnovice

    youngnovice Guest

    0
     
    thanks shadow

    thanks shadow.. fixed it before I read your comment

    actually had problems trying to install spamassassin and psa back. due to fact that atomic was spamassin 3.0 it didn't agree with the 7.5.3-fc2 version of psa which got deleted.

    Because I had those two installed I got errors. If I rebooted I got an mysql error and also when I clicked spam assassin and clicked set ... a popup would say blah blah spammng -- stop

    Ended up doing the following which I saw in the forums earlier this morning how to check versions :

    checked which version I had installed because I couldn't uninstall by running rpm -e spamassassin

    Checked version:
    rpm -aq |grep psa-spamassassin
    Output:
    spamassassin-3.1.0-4.rhfc2.art
    psa-spamassassin-7.5.3-fc2.build75050506.13

    Uninstalled
    rpm -e spamassassin-3.1.0-4.rhfc2.art
    rpm -e psa-spamassassin-7.5.3-fc2.build75050506.13

    Then installed spamassassin

    rpm -Uvh spamassassin (didn't work for me)
    so I used
    yum install spamassassin

    I added psa-spamassassin via plesk updater in the control panel because I got an error there was no such package.

    And everything is working fine.

    Thanks my plesk peeps.

    -----sleepless nights------
     
Loading...