1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

psa won't start after upgrade from 9.5.4 to 10.3.1

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by sugardaddy, Sep 14, 2011.

  1. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    I did an upgrade on a Debian server, with command line.
    Everything was doing well but psa failed to start now.

    I read a lot of threads here but nothing helped me.
    I don't know where to start... a bit disappointed.

    Thanks for your help !
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    How we can help you if you have not provided any details, logs, etc? You have only phrase - "Plesk doesn't work!"
    Try to find something useful in /usr/local/psa/admin/logs/panel.log and /var/log/sw-cp-server/error_log
     
  3. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    Yeah, that's what I mean by "where to start"... thanks for givin me something to search in.
    Well, my panel.log is empty.
    There's something in the other log file :

    2011-09-13 14:35:07: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2011-09-13 14:37:41: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2011-09-13 14:49:37: (connections.c.299) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    2011-09-13 14:49:37: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2011-09-13 14:49:43: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2011-09-13 16:44:09: (connections.c.299) SSL: 1 error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate
    2011-09-13 16:44:09: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2011-09-13 17:38:16: (log.c.135) server stopped
    2011-09-13 17:49:43: (log.c.75) server started
    2011-09-13 17:49:43: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2011-09-13 17:49:43: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2011-09-13 17:50:30: (log.c.135) server stopped
    all children busy, launch additional (total 2, limit 30)
    all children busy, launch additional (total 2, limit 30)
    all children busy, launch additional (total 2, limit 30)
    all children busy, launch additional (total 2, limit 30)
    all children busy, launch additional (total 3, limit 30)
     
    Last edited: Sep 14, 2011
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    The next step of investigation is searching in KB articles - http://kb.odin.com
    Did you try it?
     
  5. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    I found something about the sw-sso package...
    http://kb.odin.com/en/112251

    I have one more file : sso.socket.sh

    I found that 00-sso-cpserver.conf and sso-cpserver.conf are not part of any package... sw-sso was not installed at all !!

    I did it.
    But... these files are not part of any package, again. And this doesn't fix my problem.
     
    Last edited: Sep 14, 2011
  6. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    And now, if I remove the package to reinstall it, it appears that there's no current version or candidate. State : is not a real package...
    Weird !!!!!!!
     
  7. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    Ok now, I don't know how, psa starts... but not drwebd service
    There's always an error in the sw-cp-server logs :

    2011-09-14 15:29:23: (log.c.75) server started
    2011-09-14 15:30:53: (connections.c.299) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request

    And I can't login to plesk panel. I have a 404 error on a "relay" page.
     
  8. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    Something new on the web admin when I launch it :
    No SP with id=ihhl3wego6rs247fbohz4ebtxdd901gau0u
     
  9. sugardaddy

    sugardaddy New Pleskian

    22
    57%
    Joined:
    Mar 15, 2007
    Messages:
    18
    Likes Received:
    0
    Ok I disabled sso... and that makes the trick ;-)
    /usr/local/psa/bin/sso --disable
     
Loading...