1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Python 2.3 and Plesk 7.5.4?

Discussion in 'Plesk for Linux - 8.x and Older' started by acidbox, Oct 27, 2005.

  1. acidbox

    acidbox Guest

    0
     
    I'm trying to install trac 0.9 for subversion, and it has a million requirements, not very fun. The first requirement is Python 2.3. Plesk has mod_python 3.03, and running python from the command line shows Python 2.2.3.

    So, my question is, what is the best way to upgrade Python to version 2.3+ without breaking anything? Should I use the Mod_python 3.1.4 installation files or the regular python installation files or is there something special I need to do in order to not break mod_python?

    Running Plesk 7.5.4 RHEL3

    Thanks for any help.
     
  2. acidbox

    acidbox Guest

    0
     
    Ok, so nobody knows.


    Is there at least anywhere on the plesk site that says what the latest version of python / mod_python that Plesk 7.5.4 supports?
     
  3. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    I would also like to update my Python to version version 2.4 so that I can use DenyHosts (http://denyhosts.sourceforge.net/)

    It appears on my Plesk Linux 7.5.4 and Plesk Expand I still have older versions. What will I break? How do I upgrade Python?
     
  4. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    The version of Python is not dependant on Plesk but on the OS you're running. The official RHEL3 channels apparently have 2.2.3, but maybe some other channel has newer rpms for RHEL3. Or you could install from source yourself.

    BTW, I prefer fail2ban over denyhosts myself, but fail2ban also needs python 2.3 or higher.
     
  5. kuhle

    kuhle Guest

    0
     
    I have Plesk 8.1 and I need to know where python is installed and how to access it:

    Your web server must have Python 2.2 or later installed.
    You must know the command that launches Python. (Generally, this is python, but may vary by installation. For instance, if the web server has two versions of Python installed, the earlier version may be invoked by the command python and the later version may be invoked by the command python2.)

    Can anyone help and let me know the answers please?
     
  6. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    It depends on your OS, but like the instructions say: it's probably just python.
     
Loading...