1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail configuration

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by mirage, Feb 1, 2009.

  1. mirage

    mirage Guest

    0
     
    Ok, so I'm officially going bonkers.... Searched hi and lo... but without success.

    I keep getting the infamous triple bounce from qmail.

    My hostname is alderaan.innernine.com.

    The domain innernine.com is hosted on that machine.

    But mail is hosted elsewhere. In fact I'm not hosting any mail on this Plesk server at all. All turned off. But I'm sending mail from websites, etc.

    In the maillog, I can see that the system is trying to send to three email addresses in succession - over and over and over again:

    1. root@alderaan.innernine.com
    2. anonymous@alderaan.innernine.com
    3. postmaster@alderaan.innernine.com



    What I want to simply forward those messages to another account. So I tried to set this up in the alias files and even the user control files for root

    As mail is disabled for all hosted domain my rcpthosts file is empty.

    Where else can I look?

    Here is that log section that repeats over and over:
    I'm sure that you guys have seen this before. I don't know why it's failing to create a temporary file - much less do I have a clue 'where' this file fails to create, ergo I can't verify permission issues.



    Oh and also - just trying to tackle all this: When trying to change the hostname in the Plesk Control Panel - it always reports an error - regardless of what I change it to (i.e. it doesn't matter whether I have an A record for the hostname or not):

    Error: Incorrect DNS record values were specified.

    Interestingly enough - It does change the hostname in the control panel regardless of the error. But checking 'hostname' in the shell, it's still the same. So I'm pretty sure this is just a bug. I host a lot of DNS on this machine and it's all working hunky dory.

    Finally:
    Why is it that when I add a domain alias to a domain with Mail Service enabled it's added to the qmail rcpthost file, but when I create a subdomain, then it's not? Sounds again like a bug to me.

    Any takers?

    My system is running fine, but it just bugs the living daylights out of me that a) Something is not working right and logs are bleeding with this error and b) I seem to have no control over fixing it? What good is Plesk then?

    Thanks for any help,
    Juergen
     
  2. atrias

    atrias Guest

    0
     
    this solved the same problem for me

     
  3. mirage

    mirage Guest

    0
     
    Thank you atrias.

    I decided to switch to postfix and that made my problems go away. But I do appreciate your response.
     
  4. Tomas J. Fulopp

    Tomas J. Fulopp Guest

    0
     
    atrias, your solution has saved me as well, after Parallels refused to help on this, saying it was not part of the control panel and they were not responsible for such command-line changes. (While they actually described the method themselves in this forum at http://kb.odin.com/en/3439).

    I've summarized my experiences with alias domain mail redirects here -- hope it helps others.
     
  5. elger

    elger Guest

    0
     
    For me too, I could not send mail to root (which I redirect in the /var/qmail/alias/.qmail-root)

    I'd like to think I know about all the basic qmail stuff like the me, locals, rcpthosts and morercpthosts. Still I got the tripple bounce message.

    As I upgraded a default (not customised) Plesk server from 8.6.0 to 9.0 and then 9.0.1 through the control Panel. I regard this to be a bug which sould be fixed by Plesk.
     
Loading...