1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Qmail / Exchange server Settings

Discussion in 'Plesk for Linux - 8.x and Older' started by littlefrog, Mar 10, 2005.

  1. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    Heres the senario:

    Domain hosted with me abccompany.com running full hosting everything is ok. Then one day some tech guy walks in their office and sets up a pritty advanced network. They take his advice and decide to get local file server running MS Exchange.

    They then decide to also have third party host DNS settings.

    Not a problem for I get requests to change DNS settings for MX record and I do.

    Then I find out that scripts generating emails on my server are dropping emails in the local boxes which are no longer exist.

    Furthermore if I send email from my computer using my domain as my outgoing mail server they also are delivered in the same manner. (i also have domain hosted on same server).

    Upon tailing the maillog qmail still thinks the mail is local.

    Is there anyway to change this and make qmail use qmail-remote instead of qmail-local when it attemps delivery of their mail. .... well change that can be made that will not be over written by plesk next time an email address or domain is created?????????????
     
  2. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    UPDATE:

    Found out that if I forward the email sent to abccompany.com to xyzcompany.com and have the mail boxes at xyzcompany.com forward back to abccompany.com it works.

    I think this is why, The qmail sendmail wrapper seems to only check the virtualdomains file whereas when the emails are forwarded the qmail deamon sending the mail must check DNS records and forwards it off my system.

    I never tried making a mailbox and have it forward to itself... but might work like that as well.
     
  3. faris

    faris Guest

    0
     
    Would it not be easier to disable email for the domain? In this way, local services on your plesk machine will know that email is not local, look at mx record, and send email to the exchange server.

    Faris.
     
Loading...